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1 Introduction

Light System Manager controls 1,300 high-performance LED fi xtures installed within the elevator shafts 
and antenna mast of the CN Tower in Toronto, Canada. The entire LED installation consumes 60% less 
energy than the fully illuminated Tower of the 1990s.

Welcome to Light System Manager
Light System Manager (LSM) is a versatile hardware and software solution optimized 
for a wide range of medium and large-scale LED lighting environments, including 
architectural, entertainment, and retail lighting applications.

Light System Engine (LSE) controller, the hardware component, delivers light output data 
via standard Ethernet hardware. LSE supports installations ranging from simple interior 
spaces to complex exterior confi gurations.

Light System Composer (LSC) design software offers sophisticated light show effects, 
playback options, and automatic discovery of all lighting components in an installation.

Key Features
 ▪ Hardware support for medium and large-scale environments — LSE hardware 

processes simultaneous light output data for up to 15,000 individually controllable 
LED nodes, depending on confi guration. 

 ▪ Improved reliability — Solid-state drives reduce the number of moving parts to 
enhance the reliability of the LSE hardware. 

 ▪ Slimmer profi le — Slimmer form factor offers convenient surface mounting, as well 
as the ability to install in server racks and racknmount cases.

 ▪ Flexible mounting options — Integrated mounting tabs allow installation overhead, 
on vertical surfaces, or on moving architectural or entertainment features.
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 ▪ Easy to use — Featuring Ethernet-based control and automatic lighting system 
discovery, Light System Manager dramatically simplifi es installation.

 ▪ Packaged with Light System Composer — LSC software allows you to create and 
manage dynamic light shows with fully customizable effects, multi-layer editing, and 
unique color palettes. You can design shows with color-changing effects, animated 
images, geometric patterns, and more.

 ▪ Versatile zone usage — Confi gure and control multiple playback  zones, each with 
unique light show assignments. Light System Manager allows simultaneous control of 
both indoor and outdoor fi xtures within a single installation.

 ▪ Optimized for use with the optional  Ethernet Controller Keypad — The Ethernet 
Controller Keypad is a wall-mounted triggering device that controls light shows and 
fi xture brightness at the touch of a button. LSM automatically discovers and supports 
up to 10 keypads within a single lighting installation.

 ▪ Automatic playback control — Confi gure show  scheduling based on a specifi c date, 
a day of the week, weekdays, weekends, or recurring event.

 ▪ Support for IntelliWhite® lighting fi xtures — Light System Manager offers visual 
effects with color temperature and intensity settings designed specifi cally for 
IntelliWhite white light fi xtures.

 ▪ Supports the optional  AuxBox expansion device — AuxBox automatically triggers 
up to eight light shows using any remote triggering device with a dry-contact closure. 
Via the AuxBox, you can trigger light shows by motion sensors, 3rd-party control or 
sensor systems, and more.

 ▪ Legacy DMX controller compatibility — Light System Manager supports DMX fi le 
export to the  iPlayer® 2 controller, via the included iP2 Downloader utility.

About this Guide
System Overview
Chapter 2 discusses the LSM hardware and software modules, installation planning 
topics, the light show design workfl ow, and an installation example.

Hardware and Software Installation
Chapter 3 provides hardware and software installation instructions, steps for confi guring 
a PC or Mac on your lighting network, instructions for connecting to the LSE interface, 
and steps for installing the latest fi rmware and LSC software versions (as needed).

Creating a Map
Chapter 4 details the process for automatically discovering lighting network components, 
including all KiNET interfaces (Power / Data Supplies and Data Enablers) and lighting 
fi xtures in the lighting network.

Fixture Placement and Groups
Chapter 5 provides instructions for editing fi xture placement and orientation, grouping 
fi xtures, and creating an animation template for use with the animation effect.

Designing Shows
Chapter 6 covers how to create, refi ne, and test light shows using a palette of visual 
effects and customizable effect parameters.

AuxBox Expansion Device

Ethernet Controller Keypad

D  KiNET™ Ethernet is the high-
performance network protocol 
engineered by Philips Color Kinetics 
for LED lighting control.
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Confi guration
Chapter 7 describes how to schedule light show playback, create playback zones, and 
upload confi guration fi les to the LSE.

Using Controller Keypads
Chapter 8 details how to confi gure keypads, including both serial and Ethernet-based 
versions. Chapter 8 also describes AuxBox confi guration.

Managing and Playing Light Shows
Chapter 9 covers the Playback module, which enables you to trigger show playback 
from a computer on the lighting network.

Confi guration Tools
Chapter 10 covers how to use the tools and utilities included with LSM.

Tutorials
Chapter 11 contains multiple tutorials covering LSM topics, such as creating multi-
layered light shows and how to work with ColorReach™ Powercore fi xtures in 
6-channel mode.

Reference
Refer to Appendix A for detailed descriptions of all on-screen palettes, menu items, 
and tools, for each software LSC module. Appendix B contains a DMX table. Appendix C 
offers basic network troubleshooting information.

Related Documents
The following PDF documents are available for download via the web at: 
www.colorkinetics.com/ls/controllers/lsm/.

 ▪ Light System Manager Installation Instructions

 ▪ Light System Manager Quick Start Guide 

 ▪ Light System Manager Specifi cation Sheet

 ▪ Light System Manager Product Guide

Documentation for the optional Ethernet Controller Keypad is available online from: 
www.colorkinetics.com/ls/controllers/enetkeypad/.

Documentation for the optional serial Controller Keypad is available online from: 
www.colorkinetics.com/ls/controllers/controllerkeypad/.

Documentation for the optional AuxBox is available online from: 
www.colorkinetics.com/ls/controllers/auxbox/.

D QuickPlay Pro addressing software 
is available online at: www.colorkinetics.
com/support/install_tool.

D The Controller Keypad utility and 
iP2 Downloader tool are included with 
LSM, installing automatically with Light 
System Composer.

E Appendix A contains a detailed list 
of all on-screen palettes, menu items, 
and tools.

E You will need Adobe Reader® to 
view PDF documentation. You can 
download the current version of Adobe 
Reader at: get.adobe.com/reader/.



8 Chapter 1

 Technical Support Contacts
Contact Philips Color Kinetics technical support for assistance with hardware or 
software questions:

Phone
888.385.5742, press option number 3 (toll free US, Canada and Mexico)

617.423.9999, press option number 3 (toll worldwide)

Email
technicalsupport@colorkinetics.com

Web
www.philipscolorkinetics.com/support
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2 System Overview

Light System Manager manages eight separate LED lighting zones onboard the Costa Concordia, the largest 
ship of the Costa Cruise line fl eet. Custom-designed chandeliers resembling colorful, glowing sea urchins, 
greet passengers in the main atrium.

Introduction
This chapter covers Light System Manager hardware and software components, 
installation planning considerations, the light show design workfl ow, and an example of a 
completed LSM installation.

There are two primary Light System Manager components: Light System Engine hardware 
and Light System Composer show authoring software. Light System Composer resides 
on a separate computer that can be disconnected from the lighting network once your 
light shows are programmed, confi gured, and uploaded to LSE. 

 Hardware Overview
Light System Engine
LSE is a controller capable of managing thousands of LED lighting fi xtures. LSE's 
Ethernet-based design enables two-way communication with components in the lighting 
network, allowing automatic discovery of all  KiNET interfaces (Data Enablers and Power 
Data / Supplies) and fi xtures. 

Supporting Hardware
One or more Ethernet switches,  CAT-5e cabling, and a personal computer (PC or Mac, 
for initial programming and setup) are required for the LSM installation. LSE stores all 
light show, confi guration, and playback scheduling data on its  hard drive.

D Once programmed and 
confi gured, LSE functions as a 
standalone playback device on your 
lighting network.
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Optional Hardware
Controller Keypads (RS-232 serial connection) and Ethernet Controller Keypads are 
optional wall-mounted devices used to manage LSM installations. All keypads feature 
touchbutton show playback, brightness, and fi xture On / Off controls. 

The  AuxBox expansion device is also compatible with LSE, over serial connection. 
AuxBox triggers show playback via up to eight contact closure-type switches.

Light System Composer Software Modules
Light System Composer is a light show design and playback software package. There are 
four modules in Light System Composer, which you use in the following order:

1.  Management Tool

2.  Show Designer

3.  Confi g Maker

4.  Playback Control (optional, for show triggering from a computer)

Management Tool

Management Tool automatically discovers all lighting components, allowing you to rapidly 
map your installation. The map identifi es all data interfaces and fi xtures by name and IP 
address, allowing LSE hardware to locate each device and accurately route light show 
data. Additionally, Management Tool allows you to create a node display order, which 
specifi es how light show effects appear on the fi xtures.

Show Designer

Show Designer allows you to author and refi ne light shows using fi xed color and chasing 
color effects, animated image effects, and geometric patterns. To create a basic show, 
you apply pre-defi ned effects to the map and then customize the effects by modifying 
their parameters. You develop a timeline by specifying start and end times for each 
effect. Once your show is complete, you can review your design using the Show 
Simulation feature.

E Refer to Chapter 8 for Controller 
Keypad and AuxBox confi guration 
instructions.
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Confi g Maker Module

With Confi g Maker, you can program playback zones, schedule automated show 
playback, and set triggers for external triggering devices, such as the Ethernet 
Controller Keypad and AuxBox. Once confi guration is complete, the Confi g Maker 
module provides a utility for uploading the confi g fi le to the LSE, where it is stored on 
the hard drive. 

Playback Control Module

Use Playback Control to view the fi le name of the currently playing light show, override 
automated show playback by triggering a live show, pause LSE playback, or refresh LSE 
playback. The Playback Control module also allows you to view scheduled events and 
access system information.

Software Utilities
QuickPlay Pro
As part of the implementation process, all KiNET interfaces and fi xtures must be 
confi gured with unique device names, IP addresses, and / or light number addresses. 
Unique naming and addressing allows LSE to differentiate between devices in a network. 
QuickPlay Pro performs addressing and naming functions for all possible types of 
hardware used in an LSM installation requiring an external addressing tool. Refer to the 
Addressing and Confi guration Guide for instructions on confi guring devices with onboard 
addressing tools.

 Keypad Confi g Tool
From the factory, Ethernet Controller Keypads from Philips Color Kinetics are 
assigned identical device names. The Keypad Confi g Tool enables you to quickly rename 
Ethernet-based keypads, simplifying the discovery process when multiple keypads are 
connected.

 iP2 Downloader
The iP2 Downloader writes fi les to DMX format and enables you to upload them to any 
iPlayer 2 controller for playback.

E  For detailed QuickPlay Pro 
instructions, refer to the Addressing 
and Confi guration Guide available 
at www.colorkinetics.com/support/
addressing/.

E Refer to Chapter 10 for Keypad 
Confi guration Utility and iP2 
Downloader instructions.
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Planning the Installation
Isolated Local Area Network
Your LSM installation must comprise an  isolated LAN (Local Area Network):

 ▪ Typical networks are confi gured to prevent a single device at a single IP address from 
monopolizing bandwidth. However, LSE is designed to have complete control of the 
network, as it is transmits large amounts of light output data each second.

 ▪ LSE performs broadcast operations when discovering lighting components, requiring 
complete control of the network.

 ▪ LSE functions as an IP address server to any computer on the lighting network 
confi gured for DHCP.

Network Installation Considerations

Light System 
Manager

Ethernet 
Controller
Keypads Ethernet

Switch

ColorBurst 
Powercore

Fixtures

Data Enabler Pro

100 – 277 VAC

CAT 5e Cable

CAT 5e Cable

CAT 5e Cable

PC or Mac 
Computer

Light System Engine communicates with lighting components via  KiNET Ethernet, the 
proprietary network protocol developed by Philips Color Kinetics for lighting system 
control. The advantages of KiNET over standard DMX lighting networks include 
bi-directional communication (enables device discovery) and support for large lighting 
installations with thousands of LED nodes.

KiNET is fully compatible with standard network hardware — LSE communicates 
with the Power / Data Supplies and Data Enablers via standard Ethernet wiring and 
components. Power / Data Supplies and Data Enablers capture and convert segments of 
the data stream into discrete DMX channels, which are compatible with all models of 
LED fi xtures from Philips Color Kinetics.

LSE accommodates network trees up to three layers deep. For optimal performance, 
use a  Gigabit Ethernet (10 / 100 / 1000 mbps) switch at the top layer of the network tree 
(the layer connected to the LSE) and Gigabit Ethernet or  Fast Ethernet (10 / 100 mbps) 
switches for the second and third layers of the tree.

The  LSE IP address is hard-coded to 10.1.3.100. Note that all other addressable 
components in the network must have an IP address in the 10.X.X.X range and a subnet 
mask of 255.0.0.0.
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 CAT-5e cabling is required for the lighting network. It is recommended that a network 
professional installs the wiring, preferably with factory-terminated cables. Per the 
Ethernet standard specifi cation (IEEE 802.3), Ethernet cables cannot exceed 323 ft 
(100 m) between network devices. For example, cables from the LSE to the farthest 
Power / Data Supply or Data Enabler cannot exceed 323 ft (100 m).

Per the Ethernet standard specifi cation, if using  Ethernet Controller Keypads, note that 
you must use PoE (Power over Ethernet) compatible network switches, or use PoE 
injectors (available from Philips Color Kinetics) inline between each keypad and switch.

Lighting System Installation Considerations
Philips Color Kinetics offers lighting systems suitable for environments ranging from 
the simplest to the most complex. A simple LSM installation might use 25 ColorGraze® 
Powercore fi xtures installed in a single zone, whereas a larger LSM installation might use 
150 strands of iColor® Flex SLX and 50 modules of iColor Module FX displaying light 
shows in multiple zones. Regardless of the complexity of your installation, keep these 
suggestions in mind:

 ▪ Create a lighting design (CAD layout, architectural plan, or other diagram) that 
specifi es the locations of all lighting fi xtures, Power / Data Supplies, Data Enablers, 
Ethernet switches, Ethernet cables, the Light System Engine, and keypads. 

 ▪ Use the interactive  Confi guration Calculator from Philips Color Kinetics, and the 
appropriate Product Guides and wiring diagrams, to determine the number of 
fi xtures each circuit in your installation can support.

 ▪ As part of the lighting design plan, where possible, make use of a repeated layout that 
specifi es the preferred orientation of each fi xture.

 ▪ To streamline physical installation and future maintenance, affi x a weatherproof label 
identifying installation placement, IP address, and device name to an inconspicuous 
location on each Power / Data Supply, Data Enabler, and fi xture housing.

 ▪ If installing in hard to reach areas, test, address, and confi gure the fi xtures before 
physically installing them.

Addressing and Confi guration
Prior to mapping your lighting components with LSC, use  QuickPlay Pro, or built-in 
device addressing tools, to assign unique IP addresses and device names to the Power / 
Data Supplies, Data Enablers, and addressable fi xtures in your lighting network. When 
addressing and naming components, use a logical IP addressing scheme or convention 
that identifi es where each device is located.

 Addressing Methods
 ▪ Serial addressing applies to most Chromacore fi xtures (Chromacore fi xtures receive 

light numbers based on serial numbers).

 ▪ Base light number confi guration applies to all Chromasic fi xtures and also iColor® 
Accent Powercore fi xtures.

 ▪ Onboard addressing applies to fi xtures and Power / Data Supplies that have onboard 
hardware addressing controls. QuickPlay Pro is not used to address fi xtures or 
Power / Data Supplies that have onboard addressing features.

E Fiber optic cabling can extend 
distances between Ethernet devices. 
Refer to your optical fi ber device user 
documentation for installation details.

E For additional PoE device details 
and ordering information, refer to the 
Ethernet Controller Keypad Product 
Guide available at: www.colorkinetics.
com/ls/controllers/enetkeypad/. 

D The Confi guration Calculator is 
available online at: www/colorkinetics.
com/support/install_tool/. 
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Workfl ow: Creating and Displaying Shows
1. Create a Map
Mapping the installation is the fi rst step in creating a light show. The map links all lighting 
fi xtures, Power / Data Supplies, and Data Enablers to the LSE, and acts as a virtual 
representation of the installation. The  Management Tool module in LSC enables you to 
automatically discover all lighting system components on the map. When new fi xtures 
are added to an existing installation, or when working off site, the Management Tool 
module also allows you to manually add interfaces and fi xtures to the map. Once all 
lighting components are mapped, you can organize them into groups. Groups create a 
sequential order by which fi xtures display light output.

2. Create a Light Show
When a map is completed, the next step is to create a light show with one or more 
effects. The  Show Designer module lets you add effects to each group of fi xtures in the 
installation and then modify the effect parameters to create unique results. Effects can 
be stacked for added depth and sophistication. Once effects are assigned, you can use the 
simulation feature to test and refi ne your show.

3. Create Playback Schedules, Zones, and Triggers
When you have built a map and designed one or more light shows, the next step is to 
confi gure playback schedules, playback zones, and remote device triggering in the  Confi g 
Maker module.

4. Upload to  LSE
After uploading the fi les created in steps 1 through 3, LSE automatically plays designated 
light shows according to a schedule or when triggered by an external triggering device 
(keypad or AuxBox, for example). No external computer is necessary for playback 
— LSE functions as a standalone controller (you can remove the PC or Mac from the 
isolated lighting network).

5. Playback Control
Optionally, you can use the  Playback Control module to override automatic LSE 
scheduling and triggers show from a computer connected to the installation.
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Installation Example
The Philips Color Kinetics headquarters comprises 50,000 square ft (4,645 m2) of offi ce, 
laboratory, and showroom space that utilizes LED lighting technology throughout. Light System 
Manager is the control solution managing multiple lighting  zones in the building, including the 
lobby, conference rooms, work spaces, exterior signage, and product demonstration areas.

Maps

One of several maps used by Light System Manager to manage light shows at the Philips Color Kinetics 
headquarters. This map represents the ceilings and walls of the lobby space, in two-dimensions.

LSM uses two-dimensional maps to identify and control the lighting components in each lighting 
zone. The lobby map contains four rectangular clusters of fi xtures, with a row of cove lighting 
fi xtures on either side. The larger rectangular areas of the lobby map correspond to the main 
ceiling, and the smaller square areas match the wall surface / ceiling adjacent to the elevator. 
The thin lines of mapped fi xtures represent the cove fi xtures lining opposite sides of the space. 

 Light Show Effects

0 seconds 60 120  180 240 300 360 420 480 540 600 

 

The Image Scroll effect creates unique light shows in the lobby of the Philips Color Kinetics headquarters.

Still image fi les (JPEG, BMP), which LSM scrolls continuously across the lobby map, are the basis 
for several unique shows. The Image Scroll effect uses the lobby map as a virtual window to 
display a portion of each side-scrolling image fi le.
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Lighting Zones
In the lobby space, 20 unique shows ranging in duration from 10 minutes to 12 hours 
scroll gently across the ceiling, wall surfaces, and alcoves. Additionally, the fi xtures 
installed directly above the reception desk are controlled by LSM as a separate region 
within the lobby zone, allowing for warm white illumination focused on the receptionist 
work space and visitor seating area.

 

The simulation feature in the Show Designer module allows fi ne-tuning of light show parameters, timelines, 
and color palettes.

Scheduling

LSM manages the playback schedule for each zone in the building. For example, the lobby 
fi xtures display unique shows every day of the week and on certain holidays. Ethernet 
Controller Keypads installed in multiple lobby locations allow users to override 
scheduled shows at the touch of a button and select from eight additional choices.
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3 Installation

The restored Hard Rock Hotel & Casino Biloxi opened its doors on lucky 7.7.07 (July 7, 2007) after 
suffering extensive damage from Hurricane Katrina. LSM’s scalable Ethernet-based design proved critical to 
the success of the project, which features exhibits and displays in multiple LED lighting zones.

Introduction
This chapter details how to install Light System Engine hardware, confi gure a computer 
on the lighting network, install Light System Composer software, access the LSE 
interface, and update both fi rmware and LSC software (as needed).

Workfl ow Example
Before setting up Light System Manager, note the installation order of a typical project. 
You can change the order to suit your needs, but the following is a general guideline:

1. Install LAN infrastructure: Ethernet switches and cables

2. Install and address lighting components: Power / Data Supplies, Data 
Enablers, and lighting fi xtures

3. Install LSE hardware

4. Set up a computer on the lighting network (the computer can be removed 
once all map, light show, and confi guration fi les are uploaded to LSE)

5. Install LSC software

6. Update fi rmware and / or LSC software with the latest version, as needed
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 Network Installation Checklist
Use the following as a guide during network installation:

 □ Confi rm that the LSM lighting network will exist as an isolated LAN.

 □ The network tree may contain one, two, or three layers of Ethernet switches. Use a 
Gigabit Ethernet (10 / 100 / 1000 mbps) switch at the top layer of the network tree 
(the layer directly connected to the LSE). Use Gigabit Ethernet or Fast Ethernet 
(10 / 100 mbps) switches for the second and third layers of the network tree.

 □ To prevent switch overloading, leave multiple ports unused on each switch.

 □ Use a network professional to install factory-terminated CAT-5e (or better) Ethernet 
cables.

 □ Ethernet cables cannot exceed 323 ft (100 m) between network devices.

 □ Use fi ber optic Ethernet cable and hardware, as needed, for cable runs exceeding 
328 ft (100 m). Refer to the appropriate fi ber optic documentation for specifi cations 
and installation details.

 □ Use the Confi guration Calculator from Philips Color Kinetics, and the appropriate 
Product Guides and wiring diagrams, to determine the number of fi xtures each circuit 
in your installation can support. 

 □ Follow the installation steps in the Installation Instructions and Product Guides for each 
type of Power / Data Supply, Data Enabler, fi xture, Ethernet Controller Keypad, and 
AuxBox you install.

 □ If installing Ethernet Controller Keypads, use PoE (Power over Ethernet) compatible 
switches, or install a PoE Injector (available from Philips Color Kinetics) inline 
between each keypad and non-PoE switch.

 □ To be compatible with LSM, all devices and computers on the lighting network must 
have an IP address in the 10.X.X.X range and a subnet mask of 255.0.0.0.

 □ Disable any fi rewalls, wireless network adapters, or VPN connections on computers 
connected to the lighting network. Leave only the default, built-in network adapter 
enabled.

Set Up Light System Manager Hardware
1. Confi rm all components received:

▪ Light System Engine controller

▪ Power cord

▪ Software CD

2. Using a  CAT-5e (or better) data cable with RJ45 connectors, connect the Light 
System Engine to the Gigabit Ethernet switch at the top layer of the network.

3. Turn On the LSE using the power button on the front of the device.

4. Connect a computer (PC or Mac) to the top layer switch using CAT-5e (or better) 
data cable with RJ45 connectors. 

5. Turn on the computer.

E See Appendix C for help with 
basic LSM network troubleshooting.

Light System Manager Components

E The Confi guration Calculator is 
available at www/colorkinetics.com/
support/install_tool/.

E Product Guides are available at 
www/colorkinetics.com/support/
product_guides/.
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Confi guring a PC or Mac on the Network
A computer connected to the lighting network allows you to perform light show 
programming and confi guration tasks using Light System Composer software. The 
computer can be disconnected once all setup functions are complete, or the computer 
can reside permanently on the network for the purpose of triggering on-demand light 
show playback.

LSE functions as the computer’s IP address server and automatically assigns an 
IP address and subnet mask the fi rst time the computer is connected and powered on. 
To verify that IP address confi guration on the computer has succeeded, connect to the 
LSE interface from the computer.

Connect to the  LSE Interface and Set Time
With your Light System Engine (LSE) and computer connected to the network and 
powered on, test your network connection by accessing the LSE interface:

1. Open a Web browser on the computer, then type http://10.1.3.100 in the address 
fi eld and press [Enter]. The LSE interface page should appear:

2. From the LSE interface, you can set the system time and view system logs.

3. For accurate show playback scheduling, confi gure the correct system time:

a) Click Set System Time from the column on the left side of screen.

b) In the Login to Webmin dialog, enter username: lse and password: lse.

c) Click  Login to continue.
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Automatic IP Address Confi guration for Windows® Vista and 
Windows® 7
If your PC does not automatically connect to LSE interface, you may need to reconfi gure 
the computer’s network settings for automatic IP confi guration ( DHCP):

1. From the Start menu, select Control Panel, then double-click Network Connections.

2. From the Network Connections window, double-click the Local Area Connection 
icon associated with the computer’s integrated network card. Disable your wireless 
network card and any VPN connections (if applicable).

3. In the Local Area Connection Status window, select Properties. The Local Area 
Connection Properties dialog appears:

4. Click to highlight Internet Protocol (TCP / IP), then click Properties. The Internet 
Protocol (TCP / IP) Properties dialog appears.

5. Click the radio buttons to select Obtain an IP address Automatically and Obtain 
DNS Server Address automatically. Click OK.

D Record the existing IP and DNS 
addresses in case you need them for 
future use.

C Disable all wireless network cards 
and VPN connections, if present.
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6. To disable fi rewall protection, click the Advanced tab from the Local Area 
Connection Properties window. Click Settings to open the Windows Firewall 
Settings window, then select the Off radio button. Click OK.

7. Click OK to return to the Local Area Connection Status window, then click Close.

8. Restart your computer to accept the new network settings.

9. To verify that the LSE has assigned an IP address to the computer, select Run… from 
the Start menu, then type cmd. At the command prompt, type ipconfi g and press 
[Enter]. The IP Address should be in the range from 10.1.3.20 to 10.1.3.50, and the 
subnet mask should be 255.0.0.0.

 Automatic IP Address Confi guration for Mac OS X
If your Mac does not connect to LSE interface, you may need to reconfi gure the network 
settings for automatic IP confi guration (DHCP):

1. From the Apple menu or the Dock, select System Preferences:

2. Click the Network icon.

3. From the Location drop-down list, select Automatic.

4. Select the Ethernet connection:

 ▪ In Mac OS X 10.4, select Built-in Ethernet from the Show drop-down list.

 ▪ In Mac OS X 10.5, from the left-side menu, select Ethernet.
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5. If using Mac OS X 10.4, select the TCP / IP tab.

6. Confi gure DHCP addressing:

 ▪ In Mac OS X 10.4, select Using DHCP from the Confi gure IPv4 drop-down list.

 ▪ In Mac OS X 10.5, select Using DHCP from the Confi gure drop-down list.

7. Click Apply Now.

8. Restart your Mac.

 Light System Composer Software Installation
Before you install LSC, close all running applications, disable virus protection, and verify 
that your computer meets the following system requirements:

LSC System Requirements

Windows®

 ▪ Windows® Vista / 7

 ▪ 256 MB RAM

 ▪ 10 MB free disk space

 ▪ CD-ROM or DVD drive

Mac OS X
 ▪ Mac OS X 10.4.9 or better

 ▪ 256 MB RAM

 ▪ 10 MB free disk space

 ▪ CD-ROM or DVD drive

C Do not confi gure IPv6. IPv6 is not 
supported by Light System Manager.

D Record the existing IP and DNS 
addresses in case you need them for 
future use.
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Installing Light System Composer for Windows® Vista and 
Windows®  7
1. Insert the Light System Composer software CD into the CD-ROM or DVD drive on the 

computer connected to the lighting network. When the D: drive window appears (the drive 
letter may differ), double-click the LSC installer folder to expand it.

2. Double-click setup.exe to launch the Light System Composer setup wizard.

3. Click Next to begin the installation.

4. At the License Agreement screen, read the license agreement, click Agree to indicate you 
accept to the terms of the software license agreement, then click Continue.

5. When the Select Installation Folder screen appears, a default installation folder is selected 
for you. Optionally, to select another installation location, click Browse.
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6. Select Everyone or Just Me to specify the user group. Click Next to continue. 

7. At the Confi rm Installation screen, click Next to start the installation.

8. Once the installation is complete, the installation complete screen appears. Click 
Close to exit. Light System Composer is now installed on your PC.

Installing Light System Composer for Mac OS X
1. Insert the Light System Composer software CD into the CD-ROM or DVD drive. 

The LSC icon displays on the desktop. Double-click the icon to expand the folder.

2. Double-click Install LSC to launch the installation wizard. Click Continue when the 
fi rst installation screen appears.
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3. At the Software License Agreement screen, read the license agreement, click Agree 
to indicate you accept to the terms of the software license agreement, then click 
Continue.

4. Select a destination volume in which to install the LSC software, then click Continue.

5. At the Install Software screen, click Install to begin the installation. 

6. When fi nished, the system prompts to indicate the installation is complete.

7. Click Close to exit the installation wizard.

After the installation is complete, the Light System Composer folder is in the 
Applications directory on your Macintosh hard drive. 

LSE Firmware and LSC Software Versions
LSE fi rmware resides on the Light System Engine and manages playback functions. LSC 
software resides on the computer connected to the lighting network and enables you 
to program light shows. Occasionally, LSE fi rmware and LSC software are upgraded to 
provide feature improvements and enhancements. Upgrades are available from the Light 
System Manager Support page at: www.colorkinetics.com/support/lsm/.

Verifying  LSE Firmware Version
1. From the Start menu, select Programs > Color Kinetics > Light System Composer > 

Playback Control.

2. In the Playback Control module, click the Info tab. The version number appears in 
the Info panel:

3. Compare the fi rmware version to the latest version available online at: 
www.colorkinetics.com/support/lsm/.

D You can create shortcuts on the 
Dock by dragging each software icon 
located in the Light System Composer 
folder to the Dock.

Version Number
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Verifying LSC Software Version
1. From the Start menu, select Programs > Color Kinetics > Light System Composer > 

Show Designer.

2. In show designer, select Help > About Show Designer from the menu bar. The 
version number appears in the About Show Designer window:

3. Compare the LSC software version to the latest version available online at: 
www.colorkinetics.com/support/lsm/.

Upgrading LSE Firmware 
To upgrade the LSE with fi rmware from the Philips Color Kinetics website, you must 
have a CD-RW or DVD-RW drive, a blank writable CD or DVD, and media creation 
software.

1. From the LSM support site — www.colorkinetics.com/support/lsm/ — navigate to 
the latest fi rmware upgrade fi le and click the link.

2. When the fi le download screen appears, click Save to download the .ISO fi le to your 
computer. Select a location on your computer, then click Save again. 

3. After the download is complete, use media creation software to extract the .ISO 
image to a writable CD or DVD.

4. With LSE running, insert the CD or DVD into the DVD drive on the LSE.

5. Press and hold the power button located on the front of the LSE to shut down. Press 
the power button again to boot up the LSE.

6. When the LSE reboots, the update software will install automatically. This process 
takes several minutes.

7. Once the installation is complete, the CD or DVD will eject.

Upgrading LSC  Software
1. Before upgrading LSC software, you must uninstall the current version. 

2. From the LSM support site — www.colorkinetics.com/support/lsm/ — navigate to 
the latest LSC software fi le and click the link.

3. Click Open, then extract the archived installation fi le.

4. Follow the LSC installation instructions on pages 23 – 25.

Version Number
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4 Device Discovery 
and Map Creation

The wave wall installed in the Georgia Aquarium’s central plaza is 150 x 25 ft (45.7 x 7.6 m), displaying fi ve 
curving bands of color-changing light. The wall acts as an immersive visual centerpiece to incoming visitors 
and also doubles as a projection surface for video shows.

Introduction
Maps identify all KiNET interfaces (Power / Data Supplies and Data Enablers) and fi xtures 
in your installation so that LSE can accurately broadcast light output data. Additionally, 
maps allow you to group fi xtures in various confi gurations to produce sophisticated light 
shows. There are two methods for creating maps: automatic mapping and manual mapping.

 Automatic Mapping Process
Automatic Mapping Workfl ow
1. Discover  KiNET interfaces 

2. Discover the fi xtures attached to each interface

Discover Interfaces
The fi rst step in creating a map of your Ethernet network is to discover the KiNET 
interfaces installed on the network. Light System Composer automatically discovers all 
interfaces via an Ethernet broadcast operation:

1. Launch the Management Tool module:
Windows®: Select Start > Programs > Color Kinetics > Light System Composer > 
Management Tool

Mac OS X: Click the Management Tool icon located on the Dock.
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2. Click the Discover Interfaces icon from the tool bar, or select Light View > Discover 
Interfaces from the menu bar. Light System Composer queries the network and 
identifi es all interfaces. When the operation is complete, the Discover Interfaces 
wizard window appears:

3. From the Discovered KiNET Interfaces panel, highlight an interface you want to add 
to the map.

4. Click the right arrow button, or double-click a highlighted interface, to move it onto 
the Add to Map panel. To remove an interface from the Add to Map panel, highlight 
the interface and click the left arrow button.

5. Click Finish to close the wizard and add the interface to your map.

6. The Discovered Interfaces appear in the Lights / Interfaces panel of the Management 
Tool window.

Discover  Fixtures
The second step in creating a map is to query each interface so that Management Tool 
can automatically discover any attached fi xtures. Note that Chromasic fi xtures, such as 
iColor® Tile FX and iColor Flex SL, are discovered differently than Chromacore fi xtures, 
such as ColorBlast® 12 and ColorGraze® Powercore.

Discovering  Chromasic Fixtures 
1. Launch the Discover Lights Wizard by clicking the Discover Lights icon from the 

tool bar. 

2. When the Choose an Interface window appears, select an interface, then click Next.

D To select multiple interfaces, hold 
down the [Shift] or [Ctrl] key while 
making your selections.

C  ColorReach™ Powercore fi xtures 
can be programmed to operate in 
3-channel or 6-channel mode. Light 
System Composer automatically 
discovers and maps all ColorReach 
Powercore fi xtures as 3-channel devices. 
Refer to Chapter 11 for a tutorial on 
mapping ColorReach Powercore fi xtures 
already confi gured for 6-channel 
operation.
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3. The Discover Lights window appears and LSC automatically discovers all fi xtures 
attached to the selected interface.

4. After the fi xtures are discovered, click Next. The layout dialog box appears. Select 
a layout, then click Finish. The fi xtures setup screen appears:

5. In the two upper panels, select the fi xture orientation and specify a 
numbering order.

6. Leave the existing interface selected.

7. Adjust the Base DMX Address and Port Number values, as needed.

8. Enter a new base light name, or use the default name.

9. Click Add Below to add the fi xtures below the most recently added fi xtures on the 
 map. Click Add Right to add the fi xtures to the right of the most recently added 
fi xtures on the  map.

The fi xtures are added to the map and appear in the layout panel. Save the map by 
selecting File > Save Map.

D If the discovery process does not 
begin automatically, click Discover 
Lights to force start the discovery 
sequence.

D Mapped fi xtures appear on the 
map according to their base light name 
plus their light number. For example, if 
the base light name is “hallway ceiling” 
and the light number is “29,” then 
the displayed fi xture name is “hallway 
ceiling 29.” It is recommended that you 
change the default name to a unique 
identifi er based on fi xture type and / or 
physical location.
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Discovering  Chromacore Fixtures
1. Click the Discover Lights icon from the tool bar, or select Light View > Discover 

Lights from the menu bar.

2. When the Choose an Interface window appears, select an interface and 
click Next.

3. The Discover Lights window appears and Light System Manager automatically 
discovers all fi xtures attached to the interface.

4. After the fi xtures are discovered, click Next.

5. The Read Light DMX Addresses window appears. Click the Read Existing Addresses 
button. Light System Composer reads the fi xture light numbers and prompts for the 
next step in the installation.

D The Read Existing Address feature 
queries the current addresses of each 
fi xture and determines if the temporary 
addressing process is necessary.
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6. If you receive the Proceed to the sorting step prompt, the fi xtures are uniquely 
addressed (each fi xture has different DMX addresses). Proceed to Step 9 
and continue the discovery process.

If you receive the In the next step you will be able to assign them unique 
temporary addresses, in order to allow for interactive sorting prompt, the 
fi xtures are NOT uniquely addressed (some of the fi xtures share the same DMX 
addresses and must be assigned temporary, unique addresses for sorting). Click Next 
to continue.

7. The Assign Temporary Addresses window appears. Click Assign Temporary 
Addresses. LSC assigns temporary DMX addresses to the fi xtures, to enable the 
sorting process.
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8. After the temporary addresses are assigned, click Next to continue.

9. The Sort Lights window appears and the fi xtures appear with temporary DMX 
addresses. Once the fi xtures are sorted, LSC will assign permanent DMX addresses 
to the fi xtures in ascending numeric order, with the fi rst DMX address assigned to 
the fi xture at the top of the column and progressing numerically downward.

a) For installations where the fi xtures are not visible from your computer (for 
example, fi xtures installed on the exterior of a tall building), refer to a lighting design 
plan or CAD fi le with recorded serial numbers. Follow the plan or CAD fi le to sort 
the fi xtures into the proper order by clicking the Move Up, Move Down, and Flip 
Selection buttons.

b) For installations that are visible from your computer, the Sort button enables 
you to rapidly organize the fi xtures based on visual feedback. Click Sort to begin 
the sorting processes. When the Finding Light window appears, a fi xture in your 
installation displays red, and you are prompted, is light #1 red?.

If the fi xture you intend to address is not displaying red, click No. Another fi xture 
will turn red and you will receive the same prompt. Continue clicking No until the 
fi xture of choice displays red, then click Yes. 

You are then prompted, is light #2 red?, repeat the process until all fi xtures are 
sorted.
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10. Once the fi xtures are sorted, click Address Lights Sequentially. Fixtures are addressed 
according to the sort order and added to the layout based on their DMX addresses.

11. Click Finish to add the fi xtures to your map. The fi xtures are then added to the map and 
appear in the layout panel.

12. Before continuing, save your map by selecting File > Save Map. 

 Manual Map Creation
Add Tools
The Add tools located on the tool bar offer offl ine mapping functionality. With the Add tools, 
you may add interfaces and fi xtures to an existing map when an installation expands, eliminating 
the need to create a new map from scratch. You may also create  placeholder maps that can be 
associated with installations at a later time, allowing you to create maps and light shows prior to 
the completion of an actual lighting project.

Manually Adding Interfaces to a Map
1. Click the Add Interface button on the tool bar. The interface type screen appears. 

2. Select KiNET interface from the drop-down menu, then click OK. 

3. The interface editor screen appears. Enter an interface name. Accept the default IP address, 
or re-enter the interface IP address, if known. Select the appropriate interface port, then 
click OK. The interface is added to the Lights / Interface panel.

D Only create placeholder maps if 
you are certain of the exact installation 
layout. If the real-world installation 
differs from the placeholder map, it is 
likely that you will have create a new 
map from scratch using the automatic 
discovery process.

C For light shows and installations 
requiring multiple maps, ensure that 
each map has a unique name.

D For future reference, before making 
any changes, record the interface IP 
address and name should in the lighting 
design plan or CAD fi le.
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4. The interface icon appears gray to indicate that it is not associated with a discovered 
interface.

Manually Mapping Flexible String  Fixtures
Flexible string fi xtures, such as iColor Flex SL or iColor Flex SLX, are Chromasic 
fi xtures. Use the Add String button to add all string-type fi xtures to a map:

1. Click the Add String... button. The Create String dialog box appears:

2. Use the two upper panels to set the fi xture quantity, orientation, and numbering 
order. (To map only one string, enter the number 1 in both the Rows and Columns 
fi elds.)

3. Select an existing interface from the drop-down menu, or select New Interface and 
enter a port quantity to add a virtual interface to the placeholder map.

4. Set the Base DMX address and the Base Light Number. The Base DMX Address 
sets the initial address of the fi rst node in the string, and the remaining nodes are 
addressed sequentially in ascending order. Select the Port Number associated with 
the fi xture.

5. Click Add Below to add the fi xtures below the most recently added fi xtures on the 
 map. Click Add Right to add the fi xtures to the right of the most recently added 
fi xtures on the  map.

The fi xtures are added to the map and appear in the layout panel. Save the map by 
selecting File > Save Map.

 

E For a complete list of light numbers 
and corresponding DMX addresses, 
refer to Appendix B.
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Manually Mapping Tile Fixtures
1. Click the Add Tile... button. The create iColor Tile FX dialog box appears:

2. In the Choose a Tile Count box, enter the quantity of tiles in your installation, both 
vertically and horizontally. A grid of tile fi xtures automatically maps to the Layout 
panel. (To map only one tile, enter the number 1 in both the Horizontal Count and 
Vertical Count fi elds.)

3. Select an existing interface from the drop-down menu, or select New Interface and 
enter a port quantity to add a virtual interface to the placeholder map.

4. Select the appropriate Port Number corresponding to the left half and right half of 
each tile.

5. Enter a fi xture name.

6. Click OK to add the tiles to your map. The tiles are automatically added to the map 
and appear in the Layout panel.

7. Save your map by selecting File > Save Map.



36 Chapter 4

  Manually Mapping Module Fixtures
1. Click the Add Module... button. The Create iColor Module FX dialog box appears:

2. Choose a module type from the Module type drop-down list.

3. Click the layout thumbnail to toggle through the layout options.

4. From the Choose an Interface box, select Existing Interface or New Interface. 
Selecting an existing interface is only available when you are mapping a single module 
and you have previously mapped an interface.

5. Set the Base DMX address and the Base Light Number for the modules. The Base 
DMX Address sets the initial address for the modules you are adding, and the 
remaining modules are addressed sequentially in ascending order. The Base Light 
Number is an identifi er used in the LSC mapping screen and does not affect the 
fi xtures. 

6. Enter a fi xture name.

7. Click OK to add the modules to your map. 

The modules are automatically added to the map and appear in the layout panel. Save 
your map by selecting File > Save Map. 

D If the light addresses in your map 
do not match the installation, you can 
change the addresses by right-clicking 
the light from the Lights / Interfaces 
panel and selecting Edit Lights.
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Manually Adding Chromacore Fixtures
1. Click the Add RGB Lights... button. The create Pro Series (also known as 

Chromacore) Lights dialog box appears.

2. Enter the number of fi xtures you are adding in the Count fi eld.

3. Select the layout, vertical or horizontal, that best represents your installation.

4. Select an existing interface from the drop-down menu or select New Interface to 
add a virtual interface to the placeholder map.

5. Set the base DMX address and the Base Light Number for the fi xtures. The Base 
DMX Address sets the initial address for the fi xtures you are adding, and the 
remaining fi xtures are addressed sequentially in ascending order. The Base Light 
Number is an identifi er used in the LSC mapping screen and does not affect the 
fi xtures.

6. Click OK to add the fi xtures to your map. 

The fi xtures are automatically added to the map and appear in the layout panel. Save 
your map by selecting File > Save Map.

D Refer to each fi xture’s Installation 
Guide or the online Confi guration 
Calculator for the maximum number of 
Chromacore fi xtures allowed per KiNET 
interface.
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Manually Adding White Light Fixtures
1. Click the Add White Lights... button. The create White Pro Lights dialog 

box appears.

2. Enter the number of fi xtures you are adding in the Count fi eld.

3. Select the layout, vertical or horizontal, that best represents your installation.

4. Select an existing interface from the drop-down menu or select New Interface to 
add a virtual interface to the placeholder map.

5. Set the base DMX address and the Base Light Number for the fi xtures. The Base 
DMX Address sets the initial address for the fi xtures you are adding, and the 
remaining fi xtures are addressed sequentially in ascending order. The Base Light 
Number is an identifi er used in the LSC mapping screen and does not affect the 
fi xtures.

6. Click OK to add the fi xtures to your map. 

The fi xtures are automatically added to the map and appear in the layout panel. Save 
your map by selecting File > Save Map.

Associating a  Placeholder Map
Creating a placeholder map by manually adding fi xtures can save time prior to 
installation, if you are certain of the layout. Once the installation is complete, you can 
then quickly associate your existing placeholder map with the real-world installation.

1. With your computer connected to the network, and the Management Tool open, 
right-click on the unassociated interface. Select Associate with Discovered Interface.

2. From the Associate Interface dialog box, click Query for Connected Interfaces.

3. Select a discovered interface. Select from Keep Original Name and Use Name of 
Discovered Interface, then click OK.

4. Repeat the process until all placeholder interfaces are associated with the actual 
installation.
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5 Map Layout and 
Groups

The Taishin Bank Tower offers an elegant architectural design that has become a new urban landmark in 
the city of Taipei. Light System Manager displays a different light show at the beginning of each hour.

Editing the Map Layout
When you have created a map by discovering KiNET interfaces and fi xtures with the 
Management Tool, you are ready to fi ne-tune the position and orientation of fi xtures in 
the map layout panel.

In the layout panel, fi xtures appear as black icons in the order that they were added 
to the map. You can move the fi xture icons, change their order, and create groups to 
organize your installation.

 Selecting Fixtures
There are three ways to select a fi xture or group of fi xtures: capture, pick, and sweep.

Capture Selection

To capture a group of fi xture icons, click and hold the left mouse button as you drag a 
box to enclose the group. Notice that the icons turn from black to red when they are 
selected. Release the mouse button and the icons remain selected. To deselect, click the 
left mouse button in an unpopulated area, away from the selected icons.

The order in which the fi xtures are captured is the order in which they are added to 
a group.
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Pick Selection

To pick a single fi xture, move the cursor to a fi xture icon and click the left mouse button. 
You can pick multiple fi xtures by holding down the [Ctrl] key as you click each icon. The 
fi xtures remain selected until you deselect by clicking in an unpopulated area away from 
the selected icons. 

The order in which the fi xtures are picked is the order in which they are added to a 
group. 

Fan Selection

You can drag a sweep line over the fi xture icons to select them in a fan shape motion. To 
drag a sweep line, position the cursor at the pivot point of the fan line, press and hold the 
[Shift] key, then click and hold the left mouse button while dragging the cursor away 
from the pivot point. The fi xture icons turn red as the line passes over them. Release the 
mouse button and the icons remain selected. To deselect, click the left mouse button in 
an unpopulated area away from the selected icons.

The order in which fi xtures are selected in the sweep is the order in which they are 
added to a group.

 Editing Fixture Orientation and Position
Move Fixture
Using the click and drag feature, you can move the selected fi xture icons. Select the icons 
to move using one of the methods described above. Click and drag the selected group to 
a new location.

Rotate Fixture
The rotate command lets you reorient fi xture icons. Select the fi xtures to be rotated, 
then click the right mouse button and select Rotate Selection Clockwise or Rotate 
Selection Counter-clockwise from the command list.

D Icons cannot be dragged on top 
of other icons. The selected icons will 
return to their previous position if any 
icons overlap.
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Fixture Groups
Now that you’ve mapped your interfaces and fi xtures, and arranged your layout, the 
last step in refi ning your map is creating fi xture groups.

 ▪ Groups determine how light show effects are associated with fi xtures. For example, 
to apply an effect to a fi xture, it must be in a group. 

 ▪ There are two types of groups, synchronized and chasing. How effects appear on the 
fi xtures is determined by their group type.

Group Types

 Synchronized
In a synchronized group, the fi xtures work in unison to display the same output.

 Chasing
Fixtures in a chasing group work in series, in the order of their position within the 
group. For example, the fi rst fi xture (or node) in the group acts as fi xture 1, the second 
as fi xture 2, and so on. Chasing groups enable animated light show effects to appear to 
chase from one fi xture to another, then to another, and so on.

 Creating Groups

Creating a Group from the Layout Panel
1. From the layout panel, select multiple fi xtures to be included in the group.

2. Click the Add Group icon from the tool bar or select Group View > Add Group 
from the menu bar.

3. When the Group editor opens, select Keep the Lights' click order, or re-order 
the fi xtures via the numbering editor. The fi xture numbering order determines the 
sequence in which chasing effects will be displayed.

4. Click OK.

5. The new group is added to the Groups panel on the Management Tool main screen.
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Editing a Group from the Groups Panel
1. Double-click a group icon in the Groups panel.

2. The Group Editor appears with a list of available fi xtures in the lower right panel. 
Select the fi xtures to be added to the new group, then click Add. The fi xtures move 
from the Available Lights panel to the Group Members panel. 

3. Use the Up, Down, and Remove buttons to arrange highlighted fi xtures in a desired 
order.

4. Rename the group, as necessary, select the group type, then click OK to fi nish.
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Creating Groups Within Groups
1. Double-click a group icon in the Groups panel.

2. The Group Editor appears. From the Available Groups panel, select one or more 
groups to add within the current group. Click Add and the groups are moved to the 
Group Members panel. 

3. Use the Up, Down, and Remove buttons to arrange highlighted fi xtures and groups 
in a desired order.

4. Rename the group, as necessary, select the group type, then click OK to fi nish.
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Animation Template
For animated effects, an animation template is useful for maintaining the aspect ratio of 
a sequence of images. Using a template ensures that you get the desired visual effect 
without a skewed or stretched appearance.

Grouping Fixtures for an Animated Effect
When grouping fi xtures for an animated effect, consider the desired visual effect. 
For example, if you want the animated effect to play on individual tile fi xtures, create 
separate groups for each tile. If you are using multiple tiles, or a rectangular array of 
iColor Flex SL / SLX fi xtures confi gured as a single viewing surface, create a group that 
includes all of the fi xtures.

Creating an Animation Template
1. After arranging the light icons in the Lights panel to match the installation, select 

Layout View > Create Animation Template. Enter a fi le name at the prompt, then 
click Save. 

2. The template grid size dialog box appears. Enter a grid size and click OK.

3. You now have a template that you will insert into your animation fi le as a layer and 
use as a size guide for creating animation fi les. Format your animation to fi t the 
template.

4. Select Edit > Save Map to save your work.

D The Template Grid Size sets the 
resolution, in LED nodes, of your 
animation. The smaller the grid size 
the, greater the density. For example, a 
grid size of 1 equals 1 node per 1 pixel 
and a grid size of 12 equals 12 pixels 
per node.
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6 Creating Shows

A popular Philadelphia landmark, Boathouse Row comprises twelve boating clubs in ten architecturally distinct buildings. 
Using the intuitive features of the Show Composer module in Light System Composer, the lighting design team rapidly 
achieved their vision of vibrant color and effects.

Introduction to Show Designer
When you have mapped your installation and assigned the fi xtures to groups in 
Management Tool, you are ready to create a light show by applying effects. The Show 
Designer module lets you apply single or multiple effects to groups and edit the effect 
properties to create a custom show.

 Workfl ow Example: Creating a Light Show
1. Load a map

2. Add effects

3. Edit effect parameters

4. Develop a timeline

5. Defi ne transitions

6. Save the show (.SHO) fi le 
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Launching  Show Designer
Windows®

Select Start > Programs > Color Kinetics > Light System Composer > Show Designer, 
or double-click Show Designer from the Color Kinetics Light System Composer folder 
installed on your desktop.

Mac OS X
Click the Show Designer icon located on the Dock.

Creating Shows
Loading a Map
Before you can create a light show, you must create a map of the installation and arrange 
the fi xtures into groups. If you have not created a map, use the Management Tool to 
automatically map your installation or a manually create a placeholder map. Placeholder 
maps are good tools for authoring practice shows and getting familiar with Light System 
Composer.

1. Launch Show Designer

2. Load a map by clicking the load map icon or select File > Load Map... from the menu 
bar. Navigate to the location of your .MAP fi le, select it, and click open. The effect 
panel column titles and the effect buttons located below the effect panel are now 
active, and the simulation window is available.

Adding Effects
Now that you have loaded your map, you are ready to begin adding effects and assigning 
them to a group:

1. From the pop-up list located below the effect panel, choose an effect type, then click 
New Effect. 

D When you launch Show Designer, 
all command buttons are inactive. This 
indicates that you do not have a map 
loaded.

C If the simulation window does 
not immediately appear, click Show 
Simulation from the tool bar or select 
Simulation > Show Simulation from the 
menu bar.

E Refer to Chapter 4 for mapping 
instructions.
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2. The effect is added to the effect panel, and its parameters appear in the parameter 
settings box:

The following fi elds contain standard effect options, applicable to all effect types:

Name: Double-click the effect name to replace the default name with one of 
your choice.

Type: To change the effect type, click the arrow and select a different effect from 
the drop-down list of effects.

Group: Assign the effect to a fi xture group by selecting the group from the 
drop-down list.

Priority: Set the effect priority by entering a numeric value. Effect priority enables 
you to stack multiple effects in the same group.

Start: Manually set the start time, in seconds, or view the start time defi ned in the 
time settings.

End: Manually set the end time, in seconds, or view the end time defi ned in the 
time settings.

Fade In: Set a transition time at the beginning of the effect.

Fade Out: Set a transition time at the end of the effect.

3. After adding the effect, you are prompted to select a group. Click the down arrow 
under the group title and select a group.

4. You can immediately view the effect on the group you selected in the simulation 
window. To view the effect on your fi xtures, select Simulation > Enable  Live Play 
from the menu bar.

5. Continue adding effects and assigning them to groups.
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 Editing Effects

About Effect Priority
Assigning effect priority lets you create sophisticated results by stacking multiple effects 
on a single group. For example, a background effect is the lowest level in the stack, so its 
priority is set to zero. Additional effects, with transparent backgrounds, are applied over 
the background effect and receive higher priority numbers. This technique allows the 
background to "show through" the higher priority foreground effects.

Using priority levels, you can combine a Random Color effect with a white Sparkle effect 
by assigning both effects to the same fi xture group, and  then setting the priority of the 
Random Color effect to zero, setting the priority of the Sparkle effect to one, and setting 
the Sparkle background color to transparent.

 Setting Effect Priority
1. Select the priority of the effect you are changing by clicking in the Priority box.

2. Enter a new value and press [Tab] to accept the change and move to the next fi eld, 
or click anywhere in another box.

Creating a  Timeline: Setting Effect Start and  End Time
Light shows are typically made up of several effects running simultaneously or 
concurrently. There are three methods to set the time of each effect. You can set a fi xed 
time duration, link time to other effect times, or set cycle durations.

Setting a Fixed Time Duration
1. Select the effect by clicking in the effect line or by clicking the effect number at the 

left of the effect line:

2. In the effect line, highlight Start and enter a new value in seconds. Press [Tab] to 
accept the start time and move to the end time fi eld, or click in another fi eld in the 
effect panel.

Or, in the time settings panel located in the lower-right side of the Show Designer 
window, select Fixed At and enter the start time in seconds. Then select Fixed 
Duration Of and enter a time, in seconds.

D If effect colors appear dull or 
muted, check the effect priority settings. 
If all priorities are set to the same 
value, the effects are averaged together, 
and the result may not be what is 
desired. 
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To Link Time
Linking the time settings for effects simplifi es future editing. When you modify the time 
setting for an effect, all other effects linked to the modifi ed effect will update to refl ect 
the change:

1. Select an effect by clicking in the effect line or by clicking the effect number at the 
left of the effect line.

2. In the time settings panel, under Start Time, select Linked to the. Choose the effect 
to which you will link from the drop-down list, then select the Start radio button. 
Repeat the linking process for the End Time setting. Enter an offset value, in seconds, 
in the With an Offset Of fi eld to instruct the linked effect begin or end after the 
time set for the effect to which it is linked.

The linked times appear in the effect line with a left arrow symbol indicating that the 
times are linked.

In the example above, the start time of effect 2 is linked to the start time of effect 1, 
and will begin running one second after effect 1 begins. The end time of effect 2 is 
linked to the end time of effect 1, and will end simultaneously.

Editing Linked Time
Linked changes are unidirectional: modifi cation of a child linked effect has no impact on 
the parent effect to which it is linked. However, modifying the parent effect (to which 
other effects are linked) results in all linked effects changing accordingly.

In the example above, the start time of effect 1 was changed from one second to ten 
seconds. Automatically, the end time of effect 1 and the start and end time of effect 2 
changed by ten seconds. This feature saves valuable editing time for large light shows 
with numerous linked effects.
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Setting Cycle Durations
The duration of an effect can be set by its cycle time. Setting a cycle time ensures that 
the full effect duration is displayed before the show loops and starts over again.

1. Select the effect by clicking in the effect line or by clicking the effect number at the 
left of the effect line.

2. In the time settings panel, under end time, select A fi xed Duration of. In the cycle 
fi eld, specify the number of times you want the effect to run.

A loop symbol appears in the end time fi eld of the effect line to indicate that the duration 
is set to fi xed number of cycles.

Time Settings Example
In the following example, effect 1 begins and runs for 15 seconds. The start and end time 
for effect 2 is linked to the start and end time for effect 1; therefore, effect 1 and effect 2 
run simultaneously. 

The start time of effect 3 is linked to the end time of effect 1; therefore, effect 3 begins 
immediately following effect 1. The end time of effect 3 is set to a fi xed duration of 15 
seconds. The start and end times for effect 4 are linked to the start and end times for 
effect 3, ensuring that they will run at the same time.

The start time of effect 5 is linked to the start time of effect 1, and the end time is set to 
3, 10-second, cycles. The start and end times for effect 6 is linked to effect 5.

The results: effect 1 and effect 2 begins running, with effect 3 and effect 4 immediately 
following effects 5 and effect 6 runs throughout all other effects.

 Save Show for Download
Once your light show is complete, save it for downloading. Light shows downloaded to 
the LSE must be saved as show (.SHO) fi les. To save, click File > Save Show.
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 List of Effects and Their Parameters

 Chasing Rainbow
A Chasing Rainbow makes a smooth transition from color to color through the color spectrum. 
When applied to a chasing group, with a light-to-light offset greater than zero, the colors 
appear to follow each other from fi xture to fi xture (or node to node, where fi xtures have 
multiple nodes).

Chasing Rainbow Parameters
Cycle Time  Set the length of time, in seconds, for one complete cycle   
   through the color spectrum.

Light-to-Light Offset Set the light-to-light color range based on the color    
   wheel. See the Light-to-Light Offset example below.

Reverse Direction Select this option to reverse the direction of the chasing    
   rainbow effect.

Reverse Color Cycle Select this option to reverse the cycle through the color    
   spectrum.

Start Color  Click Choose Color to open the color selector and specify the  
   starting color. The start color also determines the saturation and   
   brightness of the entire effect. For example, if you pick a    
   start color with 50% saturation, the entire Chasing Rainbow effect   
   will use 50% saturated colors.

Light-to-Light Offset Example
Light-to-Light Offset parameter set at 10-,30-, and 90-degrees.

D The Chasing Rainbow is only 
effective when applied to chasing 
groups. 
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 Cross Fade
A cross fade is a smooth transition from one color to another. For example, a cross fade 
from red to blue starts with solid red, then begins increasing the level of blue light and 
reducing the level of red light, until it ends with solid blue.

Cross Fade Parameters
Cycle Time  Set the length of time, in seconds, for one complete cycle  
   from the starting color to the ending color.

Start Color  Click Choose Color to open the color selector, or   
   select Transparent to enable stacked effects to    
   show through.

End Color  Click Choose Color to open the color selector, or   
   select Transparent to enable stacked effects to    
   show through.
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 Custom Rainbow
The Custom Rainbow effect is similar to the Chasing Rainbow effect, but it allows you to 
choose your own color scheme.

Custom Rainbow Parameters
New Color  Click New Color, then click bar to open the color selector  
   and specify the starting color. Repeat for each additional   
   color in your rainbow.

Light-to-Light Offset Set the length of time, in seconds, it takes for a color to   
   move from light to light.

Creating a Custom Rainbow
1. After loading a map into Show Designer, select Custom Rainbow from the pop-up 

list below the effect panel, and click New Effect.

2. From the Group drop-down list, select a chasing group from the map.

3. With the effect highlighted, click New Color in the effects parameter panel. The new 
color appears in the color panel. 

4. Double-click the color box. The select color window appears. Choose a color and 
click OK. The color you selected appears on your simulation as a fi xed color.

5. Continue adding new colors to the custom rainbow. Each new color you add appears 
in the simulated chasing rainbow.

6. To change the appearance of the rainbow, modify the start time, end time, and 
light-to-light offset time parameters.
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 Fixed Color
The Fixed Color effect is a static display of one solid color.

Fixed Color Parameters
RGB Color  Use the select color palette to set the color.

 Random Color
The Random Color effect produces randomly generated colors at specifi ed intervals.

Random Color Parameters
Time Per Color  Set the length of time, in seconds, for each color to display. 
   For example, if you set the time per color to one second,  
   each random color will be displayed for one second.

Fade Time  Set the length of time, in seconds, for the transitions   
   between colors. For example, a fade time of zero   
   results in abrupt color changes. Higher fade times result in  
   longer, smoother transitions, or fades, between colors. Fade  
   time should be less than time per color.

Cycle After This  Set the number of unique colors per cycle.
Many Colors

Light-to-Light Offset Set the length of time, in seconds, it takes for a color to   
   move from light to light.

Start Color  Use the color picker to specify the starting color.
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 Sparkle
The Sparkle effect produces a series of light fl ashes at regular intervals. When applied 
to a fi xture group, each fl ash appears randomly on a different light creating a sparkling 
effect.

Sparkle is most effective when applied to groups with a large number of fi xtures — the 
more fi xtures, the better the visual effect.

Sparkle Parameters
Decay Rate  Set the time that it takes for the fl ash of light to fade into  
   the background color.

Density   Set the maximum number of fi xtures, in percentage, that   
   fl ash simultaneously during a time interval. The higher the  
   density the greater the sparkle.

Time Constant  Set the time intervals for the fl ashes. The larger the time   
   constant the faster the fl ashes appear.

Sparkle Color  Use the color picker, or select Transparent, to specify the  
   Sparkle color.

Background Color Use the color picker, or select Transparent, to set   
   the background color.



56 Chapter 6

 Streak
The Streak effect is a single pulse of color that moves across a background color. You can 
set the pulse to give the appearance of a back and forth bounce, or a one direction run 
across the background. 

The Streak effect is a single pulse of color that moves across a background color. You 
can set the pulse to give the appearance of a back and forth bounce, or a one direction 
run across the background. The Streak effect is only effective when applied to chasing 
groups. 

Streak Parameters 
Cycle Time  Set the length of time, in seconds, for the pulse to move   
   completely across the fi xtures.

Pulse Width  Set the width of the pulse in number of nodes / fi xtures. 
   A pulse width of two means the pulse is two fi xtures wide.

Forward Tail Width Set the width, in number of nodes / fi xtures, of the   
   graduated fade at the beginning of the streak.

Reverse Tail Width Set the width, in number of nodes / fi xtures, of the   
   graduated fade at the end of the streak.

Reverse   Select this option to reverse the direction of the pulse   
   effect.

Wrap   Select this option to have a pulse begin in the same   
   graduated increments as the previous pulse is    
   ending, creating a wrapping effect.

Pulse Color  Use the color picker, or select Transparent, to set the   
   pulse color.

Background Color Use the color picker, or select Transparent, to set the   
   background color.

D The Streak is only effective when 
applied to chasing groups. 
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 Sweep
The Sweep effect is a progressive transition from one color to another in a sweeping 
motion. You can set the sweep to give the appearance of a back and forth color change, 
or a one direction sweep across the light group. The Sweep effect is only effective when 
applied to a chasing group.

Sweep Parameters
Cycle Time  Set the length of time, in seconds, for the sweep to move  
   across the fi xtures.

Reverse   Select this option to reverse the direction of the sweep   
   effect.

Sweep Color  Use the color picker, or select Transparent, to set the pulse  
   color.

Background Color Use the color picker, or select Transparent, to set   
   the background color.

 XY Burst
The XY Burst effect is most effective when used on fi xtures that are arranged in a 
coordinate plane. The XY Burst is a progression of concentric bands of color moving 
from the outermost region of the fi xtures to the center. XY Burst can be applied to 
either synchronized groups or chasing groups with the same results.

XY Burst Parameters
Cycle Time  Set the length of time, in seconds, for the Burst effect to   
   move through the color spectrum, outside to center.

Ring Width  Set the size of the color rings.

Center X  Enter the horizontal distance, relative to output size, from  
   the upper left corner.

Center Y  Enter the vertical distance, relative to output size, from the  
   upper left corner.

D The Sweep is only effective when 
applied to chasing groups. 
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 XY Spiral
The XY Spiral effect is most effective when used on fi xtures that are arranged in a 
coordinate plane. The XY Spiral is arcs of color originating at the center of your light 
plane extending to the outermost region of the fi xtures. XY Burst can be applied to 
either synchronized groups or chasing groups with the same results.

XY Spiral Parameters
Cycle Time  Set the length of time, in seconds, for the Spiral effect to   
   make one complete rotation around the fi xtures.

Twist   Set the size of the radius of the arcs. Setting a negative size  
   will result in a reversed arc.

Arms   Set the number of arcs of a given color rotating around the  
   center.

Clockwise  Select this option to rotate the spiral in a right-to-left   
   rotation.

Counterclockwise Select this option to rotate the spiral in a left-to-  
   right rotation.

Center X  Enter the horizontal distance, relative to output size, from  
   the upper left corner.

Center Y  Enter the vertical distance, relative to output size, from the  
   upper left corner.
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 Animation Effect
The Animation effect lets you play a sequence of graphic fi les on your fi xtures to create 
an animated effect. This sequence of graphic fi les is created using a standard animation 
software, such as Adobe® Flash®.

Animation Parameters
Timing   Set the rate of speed that simulation and playback steps   
   through the sequenced graphic images.

Geometry  Set the distance (X-Y Offset) from the top and side that the  
   image appears

Scale Factor  Set the size of the animation on the fi xtures. The larger the  
   number, the smaller the image.

Transparent Color Set a transparent color background.

Create the Animation
Animation Workfl ow
Using animation software, create an animation fi le. In the animation fi le, insert the 
animation template you created with Management Tool in Chapter 5 as a layer, and use it 
to defi ne the size. The template ensures that you get the desired visual effect without a 
skewed or stretched appearance.

Once the animation is complete, export it as a sequence of graphic fi les. In Flash, the 
command is File > Export Movie. From the drop-down format list, select PNG Sequence. 
Save these fi les into an empty directory that will be used in Show Designer to create an 
animated effect.

Animation Setup Steps
1. Launch Show Designer.

2. Load a map by clicking the Load Map icon or select File > Load Map... from the menu 
bar. Navigate to the location of your .MAP fi le, select it, and click Open. The effect 
panel column titles and the effect buttons located below the effect panel are now 
active, and the simulation window is available. This lets you know that your map is 
loaded.

3. In the pop-up list located below the effect panel, choose Animation, then click New 
Effect. The animation effect is added to the effect panel and its parameters appear in 
the parameter settings box.

E A .PNG fi le is a Portable Network 
Graphic that is ideal for use with Light 
System Composer.

D For more information on creating 
animations, refer to the user guides for 
your animation software. After creating 
a sequence of graphic images using 
animation software, you are ready to 
create an animated effect on your 
fi xtures from Philips Color Kinetics.

D Enable Smooth to soften the hard 
edges in the animation.
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4. Select the group on which the animation will play from the group drop-down list. 

5. Locate the directory where the sequence of graphic fi les are saved by clicking the 
Browse button below the animation directory dialog box.

6. The browse for folder window appears. Select the directory and click OK.

7. Click Load to load the graphic fi les into Show Designer. The animation begins playing 
in the simulation window.

8. Confi gure the animation timing by entering the number of playback frames per 
second.

9. Set the geometry by entering an X-Y offset and setting the scale factor.

10. (Optional) Click to enable transparent color, then use the color picker to modify the 
transparent color settings.

 Image Scroll
Image Scroll allows you to move a still image across a grid of fi xtures. The Image Scroll 
effect is ideal for iColor Tile FX, iColor Flex SL, iColor Flex SLX fi xtures installed in a 
grid pattern.

Image Scroll Parameters
Timing   Set the rate of speed that the still image moves.

Geometry  Set the starting and ending locations. The image moves in  
   a straight path from the defi ned starting location to the   
   defi ned ending location.

Scale Factor  Specify the size of the still image.

Transparent Color Set a transparency as the background.

Background Color Set a background color.

Create an Image Scroll Effect
1. Launch Show Designer.

2. Load a map by clicking the Load Map icon or select File > Load Map... from the menu 
bar. Navigate to the location of your .MAP fi le, select it, and click Open. The effect 
panel column titles and the effect buttons are now active, and the simulation window 
is available. This lets you know that your map is loaded.
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3. From the pop-up list located below the effect panel, choose Image Scroll then click 
New Effect. The image scroll effect is added to the effect panel and its parameters 
appear in the parameter settings box.

4. Select the group on which the animation will play from the group drop-down list.

5. Locate the directory where the image fi le is saved by clicking below the image fi le 
dialog box.

6. Navigate to the directory in which the image is saved. Select the image and click OK.

7. Click Load to load the still image into Show Designer. The animation begins playing in 
the simulation window.

8. Set the time it takes for the image to move from the starting point to the ending 
point by entering a value, in seconds, in the cycle time fi eld.

9. Defi ne the geometry:

Output Size  The size of your light installation in output pixels, with each  
   pixel being a light or light node.

Image Size  The size of your selected image, in pixels.

a) The fi rst step in defi ning the geometry is to set the scale. Scale determines the size 
of the image on the output pixels of your light installation. When the scale is set to 
1.0, each output pixel maps to exactly one image pixel.

To reduce the size of the image on the installation, reduce the scale. For example, 
when the scale is set to 0.5, one output pixel maps to two image pixels.

To increase the size of the image on the installation, increase the scale. For example, 
when the scale is set to 2.0, two output pixels map to one image pixel.

b) Set the starting and ending points by defi ning the start X-Y position and end X-Y 
positions. 

The origin of the X-Y space is the center of the output pixels. When you set X-Y to 
0,0, this positions the top left corner of the image in the center of the light pixels.

As X increases, the image appears to move to the left. As Y increases, the image 
appears to move up.

For more information on calculating image scroll geometry, see page 62.

10. (Optional) Click to enable transparent color, and then use the color picker to refi ne 
the transparent color. Transparent color allows you layer the scrolling image effect 
with other effects.

Set Frame Rate
To set the live play frame rate, which determines the speed that data is sent and how 
your animation appears on your fi xtures, select Edit > Preferences from the menu bar. 
The edit preferences dialog box appears.

1. Set the live play frame rate in frames per second.

2. Set the live play per simulation update. The live play per simulation update sets the 
frequency that the simulation is redrawn, expressed as a number of live play frame 
passes between redraws.

Output Size
The Image Scroll Effect should be thought of as moving a “virtual window” (the map) 
over a still image fi le. The Output Size fi eld shows the dimensions, in virtual pixels, of 
your virtual window.

D LSC supports the following image 
formats: .PNG, .XPM, .JPG, and .BMP.
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Image Size
Similarly, the Image Size fi eld shows the dimensions of the selected image, in pixels.

 Calculating X-Y and Scale Settings, in Detail
The transformation from image space to the virtual window space is performed 
as follows.

1. The Scale factor setting is applied to the virtual window. 

a) When the Scale is set to 1.0, each virtual pixel maps exactly to one image pixel. 

b) When the Scale is set to 0.5, one virtual pixel maps to two image pixels.

c) When the Scale is set to 2.0, two virtual pixels map to one image pixel.

2. The X and Y settings are applied to shift the image within the virtual window.

a) The origin of the X-Y space is in the middle of the virtual window, so setting X-Y 
to 0,0 positions the top left corner of the image in the center of the virtual window.

b) As X increases, the image appears to move to the left in the virtual window. To 
align the left side of the image to the left side of the virtual window, X should be set 
to the following:
(virtual window width / (2 * scale))

c) As Y increases, the image appears to move up in the virtual window. To align  the 
top of the image to the top of the virtual window, Y should be set to the following:
(virtual window height / (2 * scale))
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 White Cross Fade
The White Cross Fade is designed for use with IntelliWhite fi xtures from Philips Color 
Kinetics. A White Cross Fade is a smooth transition from one color temperature and 
intensity to another. 

White Cross Fade Parameters
Cycle Time  Set the length of time, in seconds, for one complete cycle  
   from the starting color to ending color.

Starting Color Temp Use the slider control to adjust the initial color    
   temperature, or select Transparent to enable    
   stacked effects to show through.

Starting Intensity Use the slider control to adjust the initial light    
   intensity level, or select Transparent to enable    
   stacked effects to show through.

Ending Color Temp Use the slider control to adjust the ending color   
   temperature, or select Transparent to enable    
   stacked effects to show through.

Ending Intensity  Use the slider control to adjust the ending light    
   intensity level, or select Transparent to enable    
   stacked effects to show through.
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 White Fixed Color
The White Fixed Color effect is a static display of one solid white color, with a 
confi gured color temperature and intensity level.

White Fixed Color Parameters
Input Type  Select from two models: Color Temp / Intensity, 
   or Warm / Cool.

Color Temp  Use the slider control to adjust the color temperature.

Intensity  Use the slider control to adjust the light intensity level.

Warm   Use the slider control to set an RGB value (0 - 255).

Cool   Use the slider control to set an RGB value (0 - 255).
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7 Confi guration

The entrance of 111 Buckingham Palace Road in Victoria, London offers a vibrant, eye-catching light wall 
with intelligent LED lighting controlled by Light System Manager.

Introduction
Now that the fi xtures are mapped and you have created light shows, you are ready to 
create playback zones and playback schedules, then download fi les to the LSE.

Launching  Confi g Maker
Windows®: Select Start > Programs > Color Kinetics > Light System Composer > 
Confi g Maker

Mac OS X: Click the Confi g Maker icon located on the Dock.

Creating Confi guration Files
You created a map (. MAP) fi le using Management Tool, and a show (.SHO) fi le using 
Show Designer. Now it is time to create your confi guration (.EFG) fi le and download 
everything to your LSE. The .EFG fi le contains data specifying zones, shows, and 
scheduling parameters.
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Adding a  Zone
What is a Zone?
Zones enable show playback control — all fi xtures in a zone are triggered together, 
whether from a keypad or a schedule. Additionally, you can have multiple zones react to 
an event, such as a recurring time on a specifi c day of the week.

Adding a Zone
1. Click Confi guration > Add Zone. Then highlight new zone in the left pane.

2. A new zone appears in the name fi eld. Enter a descriptive name in the name fi eld.

3. Select a map to defi ne the zone by clicking Browse at the end of the map fi le fi eld. 
From the select a map window, navigate to and select the appropriate map fi le. Click 
Open to load the map fi le and defi ne the zone. 

4. Continue adding zones and maps to your confi guration. 

C Use caution when creating zones 
and defi ning maps. A light cannot reside 
in more than one zone or map on 
the LSE. If it does, it will receive data 
from multiple sources and result in an 
unsatisfactory appearance.

D Ensure that a map is only added 
to your confi guration once. You cannot 
have the same map associated with 
multiple zones.
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Add Shows
Now that you have created zones, you are ready to add shows to those zones.

1. Click Add Shows. Select the show from the select show fi les window and click 
Open to add the show to the zone. You can select multiple shows by holding [Shift] 
or [Ctrl] while clicking on the fi le names.

2. From the default show list at the bottom of the zone dialog, select a default show 
or fi xtures off. The default show will immediately play once the show confi guration 
fi les are downloaded, or when the LSE is powered on. 

3. Continue adding shows and setting the default show for each zone that you 
created.

4. To save a copy of your confi guration fi le to your computer, select File > Save.

5. Select Controller > Download to download the confi guration fi les, which include 
zones, maps, and shows, to the LSE.

D The shows you select must be 
authored for the selected map. 
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Set  Scheduled Events
LSE lets you schedule events to play automatically on a given day, at a given time, or on a 
recurring basis. Before you can schedule events, you must create zones and add shows in 
the zone dialog.

An event will begin running on the date and time specifi ed, and recur at the specifi ed 
intervals. Once an event begins to run, it will continue running until another scheduled 
event begins, or until an event is triggered from a controller keypad or the Playback 
Control module.

To trigger a stopping time for an event, create a fi xtures off event scheduled for the date 
and time that you want the fi xtures to turn off.

1. To schedule an event, click Confi guration > Add Schedule.

2. Enter a name for the event in the name fi eld. The name is added to the events fi eld.

3. Set the start time, date and time of day, by using the scroll arrows or clicking each 
fi eld and entering the date and time. 

4. Set the  recurrence parameters:

One Time For one time settings, no timing parameters need to be set.

Secondly Enter the time, in seconds, that the event will recur.

Minutely Enter the time, in minutes, that the event will recur.

Hourly Enter the time, in hours, that event will recur.

Daily Enter the time, in days, that the event will recur. For example,  
 enter 2 for every other day, enter 3 for every third day, and   
 so on. Or select Every Weekday for Monday through Friday   
 recurrences.

Weekly Enter the time, in weeks, that the event will recur. For   
 example, enter 2 for every other week, enter 3 for every   
 third week, and so on. Select the days of the week for the   
 recurrences.

Monthly Enter the day of the month, and the time, in months, that the  
 event will recur. For example, enter day 4 of every 2 months  
 for the event to run the fourth day of every other month; or  
 enter day 1 of every 1 month for the event to run the fi rst day  
 of every month. Alternatively, enter the day of the week and  
 the time, in months, that the event will recur. For example,   
 the fi rst Monday of every month.

Yearly Select every year to have the event play every year on the   
 date and time specifi ed in the start time. Alternatively,   
 enter the day of the week and the time, and the month, that   
 the event will recur. For example, the fi rst Monday of January  
 every year.

For recurring events, set the Recurrence End parameter. Select Repeat Forever or 
End By and enter the date and time. The recurrence end controls the last date and time 
that the event will run. It does not schedule an ending time for the event.

1. Click the Edit Actions button to defi ne the event show. The edit actions dialog 
appears. Select the zone and the action from the drop-down list. Set a transition and 
click OK. 

2. Click Confi guration > Add Schedule to schedule another event, then save.
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 Sample Event Scheduling
Below is a same of a simple, multi-event schedule.

First Event

Name: Morning

Start Time: 8:00 AM

Recurrence: Daily, every day

Recurrence End: Repeat forever

Actions: purple to yellow sweep.sho 

Second Event

Name: Noon

Start Time: 12:00 PM

Recurrence: Daily, weekdays

Recurrence End: Repeat forever

Actions: blue streak.sho 
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Third Event

Name: Evening

Start Time: 7:30 PM

Recurrence: Weekly: Friday, Saturday, Sunday

Recurrence End: Repeat forever

Actions: rainbow.sho 

Fourth Event

Name: Lights Off

Start Time: 11:30 PM

Recurrence: Daily

Recurrence End: Repeat forever

Actions: Lights off 
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Results
On June 22, at 8:00 AM, the morning event will trigger the purple to yellow sweep effect 
to begin running on the installation. 

This show will continue, weekdays, until 12:00 PM when the next event, noon, triggers 
the blue streak effect to run. 

On Friday, Saturday and Sunday the blue streak effect loop will play until the evening 
effect triggers the rainbow effect to begin at 7:30 PM. On all other days the blue streak 
will continue looping until the next, fi xtures off, effect.

At 11:30 PM the lights off effect triggers all fi xtures to turn off ending the rainbow effect 
on Friday through Sunday, and the blue streak effect Monday through Thursday. 

The fi xtures will remain off until 8:00 AM when the morning event triggers and the 
process begins again.

 Download Files
After creating a show confi guration and scheduling events, you are ready to download 
your show to the LSE. Select Controller > Download to download the confi guration fi les, 
which include zones, maps, and shows, to the LSE.
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8 Confi guring 
  Controller Keypads

The Peak Tower sits on Victoria Peak, the highest mountain on Hong Kong Island. The tourist destination 
features multiple zones of LED lighting controlled by Light System Manager.

Introduction
Using a keypad in your installation lets you select a show with a quick press of a button. 
Each keypad has eight buttons that can control shows, and features brightness and On / 
Off controls.

Set Keypad
Before setting up a keypad buttons, you must create zones and add shows using the Zone 
tab in the Confi g Maker module. After setting each keypad button, you must select the 
zones to be controlled by the brightness and On / Off controls.

1. Click Confi guration > Add Keypad. Enter a name for the keypad in the name fi eld. 
The name you enter appears in the keypad list.
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2. From the Type drop-down list, select the type of controller keypad used in your 
installation, Serial (RS-232) or Ethernet.

If you are using a serial Controller Keypad, accept the default serial port /dev/ttyS0.

If you are using an Ethernet Controller Keypad, select Confi guration > Discover 
 Ethernet Keypad from the menu bar.

3. Now that you have selected the keypad, you are ready to assign actions to each 
button on the keypad. Click Button 1 to open the Edit Actions dialog.

4. Select a zone.

5. Select an action (.SHO fi le) from the drop-down list.

6. Select a transition. Transitions control the appearance of a show change when a 
button is selected.

Snap   A new show immediately begins when the button is   
   selected.

Cross Fade  The newly selected show gradually fades in as the   
   previously running show fades out.

Fade to Black The newly selected show begins after the current show   
   fades to black, and then black to new show.

7. Enter the transition time, in seconds.

8. Click OK. The trigger for button 1 is set to the zone and show you selected. 

9. If you would like button 1 to control multiple zones, click edit actions for button 1 
again. 

10. Select a different zone from the drop-down list. Select the action and set the 
transition, then click OK. Button 1 in now confi gured to trigger two zones 
simultaneously. The shows for the zones you assigned to button 1 appear in the 
button 1 list.

Continue adding zones to button 1 or proceed to setting triggers for the remaining 
buttons.

If you need to set button numbers higher than eight, use the advanced button located 
at the bottom of the window.

Show buttons
 

Dimmer controls 
On / Off controls 
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11. Click Edit Zones located at the end of the zones controlled fi eld.

12. Select the zones to be controlled from the available zones list and then click the 
right arrow to add them to the currently selected zones list.

13. After selecting all zones to be controlled, click OK.

14. If you are not scheduling events, you are ready to download your show 
confi guration fi les. Select Controller > Download to download the confi guration 
fi les, which include zones, maps, and shows, to the LSE. 

Set  AuxBox
If you are using an AuxBox to trigger your shows, you must confi gure your AuxBox 
triggers before downloading your show confi guration fi les to the LSE.

Using an AuxBox in your installation lets you select shows via contact closure switches 
such as motion detectors and electronic eyes. Each AuxBox has eight switch ports. 

Before setting up a AuxBox triggers, you must create zones and add shows using the 
Zone tab in the Confi g Maker module.

1. Click Confi guration > Add Keypad. Enter a name for the AuxBox in the name fi eld. 
The name you enter appears in the keypad list.

2. From the type drop-down list, select Serial and accept the default serial port /dev/
ttyS0.

3. You are ready to assign actions to each button (in this case, “buttons” refer to 
contact closure switch ports 1 through 8). At the end of the Button 1 fi eld, click 
Edit Actions.

4. Select a zone from the drop-down list.

5. Select an action (.SHO fi le) from the drop-down list.

6. Select a transition. Transitions control the appearance of a show change when a 
button is selected.

Snap   A new effect immediately begins when the button is   
   selected.

Cross Fade  The newly selected effect gradually fades in as the   
   previously running effect fades out.

Fade to Black The newly selected effect begins after the current show   
   fades to black, and then black to new show.

7. Enter the transition time, in seconds.

D The Confi g Maker interface does 
not natively support AuxBox. However, 
programming an AuxBox for use with 
LSM is identical setting up a serial 
keypad.
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8. Click OK. The trigger for contact closure switch 1 is set to the zone and show you 
selected. 

9. If you would like button 1 to control multiple zones, click edit actions for button 1 
again. 

10. Select a different zone from the drop-down list. Select the action and set the 
transition, then click OK. Contact closure switch port 1 in now confi gured to trigger 
two zones simultaneously. The shows for the zones you assigned to button 1 appear 
in the button 1 list.

11. Continue adding zones to button 1 or proceed to setting triggers for the remaining 
buttons.

12. If you need to set button numbers higher than eight, use the Advanced button 
located at the bottom of the window.

Discover Ethernet  Controller Keypad
To use an Ethernet Controller Keypad in conjunction with LSM, you must discover the 
keypad and confi gure it with Confi g Maker. 

1. Add keypads and assign actions to each keypad button, as described above. 

2. To discover an Ethernet Controller Keypad, press the keypad’s four corner show 
buttons simultaneously. A Discovered Keypad dialog box opens in Light System 
Composer, with the keypad’s IP address (Ethernet Interface) and a unique keypad ID 
automatically assigned.

3. Click Associate Keypad, select a keypad name from the list, and click OK.

4. Repeat steps 2 and 3 for each Ethernet Controller Keypad in your installation.

D The discovery process is not 
necessary for serial (RS-232) Controller 
Keypads.
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9  Playback Control

Duvet nightclub in Manhattan boasts ethereal, color-changing effects controlled by Light System Manager.

Introduction
Once the .EFG fi le is loaded onto the LSE, the LSE functions as a standalone playback 
device. Typically, at this point, the computer hosting LSC is removed from the lighting 
network. However, the computer can remain on the network so as to use the Playback 
Control module for triggering on-demand shows.

Playback Control also allows you to view the fi les downloaded to the LSE, review 
scheduled event confi gurations, and access LSE system information.

Launching Playback Control
Windows®: Select Start > Programs > Color Kinetics > Light System Composer > 
Playback Control

Mac OS X: Click the Playback Control icon located on the Dock.

 Triggering Shows from a Computer
1. From the Playback Control window, click the Shows tab. The Zone fi eld is populated 

with the zones downloaded to the LSE. From the Zones drop-down list, select a 
zone.

2. The shows assigned to the selected zone appear in the Show drop-down list. Click a 
show fi le from the list, then click Play. The show will begin playing on the fi xtures in 
your installation.
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3. Click and drag the slider to set the brightness level for the fi xtures in the selected 
zone. Extreme right is full brightness. Drag left to dim.

Info
1. From the Playback Control screen, click the Info tab. The Info tab provides current 
information about the LSE. 

The information contained on the info tab includes the LSE fi rmware version and loaded 
show fi les. This information is valuable for troubleshooting. When talking to a Color 
Kinetics Technical Support representative, have this information available.

Scheduled Events
1. From the Playback Control window, click the Scheduled Events tab. The Scheduled 

Events  tab lists the scheduled event on the LSE.

The information contained in the Scheduled Events tab allows you to monitor all events 
loaded to your LSE.

D Brightness control is zone 
specifi c; zone brightness must be set 
independently for each zone. 
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10 Confi guration Tools

The Chinook Centre is the largest enclosed shopping mall in Calgary, Alberta. At its center is a 60 ft 
(18.2 m) high rotunda, and during the holiday season it sparkles with a cheerful, winter display scheduled 
and controlled by Light System Manager.

Introduction
Confi guration tools help you rename and address fi xtures, KiNET interfaces, and 
controller keypads from Philips Color Kinetics. Additionally, the iP2 Downloader allows 
you to export light shows as DMX fi les for use with the legacy iPlayer 2 controller. 

QuickPlay Pro addressing and confi guration software is available for download online at:

www.colorkinetics.com/support/userguides/

The following utilities are located in the Light System Composer Utilities folder.

 ▪ Ethernet Keypad Confi guration Tool

 ▪ iP2 Downloader

 QuickPlay Pro
Overview
As part of the implementation process, all KiNET interfaces and fi xtures must be 
confi gured with unique device names, IP addresses, and / or light numbers. Unique 
naming and addressing allows LSE to differentiate between devices in a network. 
QuickPlay Pro performs addressing and naming functions for all possible types of 
hardware used in an LSM installation requiring an external addressing tool (some fi xtures 
and interfaces have built-in addressing tools).
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There are three methods for addressing fi xtures from Philips Color Kinetics, two of 
which require QuickPlay Pro:

 ▪ Serial addressing applies to most Chromacore fi xtures (Chromacore fi xtures receive 
light numbers based on serial numbers) and all ColorReach Powercore fi xtures.

 ▪ Base light number confi guration applies to all Chromasic fi xtures and iColor Accent 
Powercore fi xtures.

 ▪ Onboard addressing applies to fi xtures and power / data supplies that have onboard 
hardware addressing controls. QuickPlay Pro is not used to address fi xtures or 
power / data supplies that have onboard addressing features.

Chromacore fi xtures are programmed with light numbers via the Fixture Confi guration 
tool in QuickPlay Pro. To confi gure a Chromacore fi xture, or segment of a Chromacore 
fi xture, you enter the serial number, specify a light number, and then click Program. The 
unique serial numbers for Chromacore fi xtures can be found on barcode labels typically 
located on the back of each unit.

If your installation uses Chromasic fi xtures, the power / data supplies controlling 
those fi xtures must be confi gured. You confi gure power / data supplies using the PDS 
Confi guration Tool in QuickPlay Pro.

Launching QuickPlay Pro
Windows®: Select Start > Programs > Color Kinetics > QuickPlay Pro

Mac OS X: Click the QuickPlay Pro icon located on the Dock or in the Light System 
Composer Utilities folder.

 Keypad Confi guration Tool
The Keypad Confi g Tool lets you set names and IP addresses for the Ethernet Controller 
Keypads in your installation. This tool is benefi cial for large installations using multiple 
keypads.

Every Ethernet Controller Keypad is pre-programmed with the same generic name. 
When discovering several keypads in the Confi g Maker module, they all appear with the 
same name and offer no indication of location in the installation. However, if you give 
each interface a descriptive name such as, west wall or third fl oor, prior to confi guring 
the LSE, then your layout is easier to manage and monitor.

1. To launch the Keypad Confi g Tool from a PC, select Start > Programs > Color 
Kinetics > Light System Composer > Utilities > Keypadconfi gtool; from a Mac, click 
the Confi g Tool icon on the Dock or in the Light System Composer Utilities folder. 

2. The Keypad Confi g Tool queries the network and lists all Ethernet Controller 
Keypad interfaces in the column. Select an interface from the column. Enter a 
descriptive name and click Set.

3. Enter an IP address in the 10.2.X.X range and click Set. Ensure that each keypad has 
a unique IP address.
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 iP2 Downloader

Creating DMX Light Show fi les for iPlayer 2
Light shows downloaded to iPlayer 2 legacy controllers must be mapped with iPlayer 2 
as the selected interface and written as DMX fi les.

After creating a map with iPlayer 2 as the selected interface in Management Tool, 
create a light show in Show Designer. To write the fi le as a DMX fi le, select File > Write 
DMX. Your show is now ready to download to the iPlayer 2 using the iP2 Downloader 
tool. Note that in addition to downloading DMX show fi les to iPlayer 2, the iP2 
Downloader also lets you assign trigger numbers, and set iP2 master / slave modes.

Launching iP2 Downloader
Windows®: Select Start > Programs > Color Kinetics > Light System Composer > 
iP2 Downloader

Mac OS X: Click the iP2 Downloader icon located on the Dock or in the Light 
System Composer Utilities folder.

Downloading DMX Show Files
After creating a DMX-based show fi le using Show Designer and writing a DMX fi le, 
you are ready to download your show to your iPlayer 2. Ensure that the iPlayer 2 is 
connected to your computer and running in Program Mode.

1. From the Current Controller drop-down list, select iPlayer 2.

2. Click the radio button to select the operating mode: 

Normal Mode: The iPlayer 2 acts as an independent controller. 

Master in a Multiple Universe Installation: In a multiple iPlayer 2 installation, 
this iPlayer 2 acts as a triggering master. 

Slave in a Multiple Universe Installation: In a multiple iPlayer 2 installation, 
this iPlayer 2 receives triggering commands from the master iPlayer 2.

3. From the menu bar, select Control > Verify Add. With Verify Add enabled, iP2 
Downloader checks the fi le size and the available free space prior to downloading 
the show fi les. If the iPlayer 2 free space is too small for the fi les selected, you will 
be prompted. If you receive an insuffi cient memory prompt, delete existing fi les to 
increase the free space.

4. Click Add Show... Navigate to the DMX fi les, select one or more .DMX fi les to add, 
and click Open. The fi les are automatically downloaded to the iPlayer 2.

5. From the trigger drop-down list, select a trigger number, or no trigger.

Default Trigger
If you are not using a controller keypad, and you have multiple shows downloaded to 
the iPlayer 2, the default show must be set to trigger 1.

D iPlayer 2 is a legacy DMX 
controller which has been replaced by 
iPlayer 3 and ColorPlay 3 software from 
Philips Color Kinetics.
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Keypad Triggers
If you are using a controller keypad, set a trigger number that corresponds with a key 
number on the keypad. After downloading the DMX fi les to the iPlayer 2 and setting 
the triggers, disconnect the iPlayer 2 from the computer and connect the BNC cable to 
the iPlayer 2. This takes the iPlayer 2 out of Program Mode and returns it into Playback 
Mode.

Once the iPlayer 2 is in Playback Mode, the default show will begin to run on your 
fi xtures. 

E For information on the iPlayer 2, 
Program Mode, and Playback Mode, 
refer to the iPlayer 2 User Guide 
available online at: www.colorkinetics.
com/support/userguides/.
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11 Tutorials

 
Mi Casa Grill Cantina at The Silverton Casino Lodge features vibrant lighting from Philips Color Kinetics. 
Light System Manager controls multiple types of LED lighting fi xtures within the restaurant space.

Tutorial One: Creating a Placeholder Map
Overview
When connected to a lighting network, Management Tool automatically discovers all 
Ethernet lighting components. There are two stages of the automatic discovery process:

1. Discover KiNET interfaces (power / data supplies and Ethernet Data Enablers)

2. Discover fi xtures

However, in this tutorial, we are going to create a placeholder map. Placeholder maps 
are useful when you are offl ine, not connected to the lighting network, but know the 
location of each KiNET interface and fi xture. You can create a placeholder map and then 
associate the map with an actual installation at a later time. 

Steps
1. Open the Management Tool module.

2. Click Add Interface and leave the default interface type (KiNET) selected.

3. Click OK.

4. Enter a name for the interface, for example “PDS-60ca 01 West Hallway”

5. Enter an IP address in the 10.1.x.x range.

6. Select Add RGB Lights.

7. Enter 10 as the fi xture quantity.
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8. Select the Horizontally radio button to specify layout orientation.

9. Select the existing interface created in steps four and fi ve.

10. Enter a base DMX address as the starting DMX address for the fi rst fi xture.

11. Select a port number on the interface, for example 1 or 2.

12. Choose a base light name. For example West Hallway Cove. Management Tool 
displays each fi xture on-screen according to its light name plus its light number, for 
example “West Hallway Cove 27”.

13. Click OK.

14. Select all of the fi xtures, then select Add Group...

15. Enter a group name, then click OK.

16. Select File > Save MAP to save your work.

Later, when you are onsite at an installation for example, you can associate the map 
with the actual interfaces fi xtures in your installation. See page 38 for details on 
associating placeholder maps.

Tutorial Two: Mapping ColorReach Powercore 
Fixtures in 6-Channel Mode
Each  ColorReach Powercore fi xture comprises two panels of LED nodes. You can either 
control the entire fi xture as a single entity, or control each panel of nodes separately. 

 ▪ If controlling the entire fi xture as a single unit, three channels of DMX data are 
required. 

 ▪ When controlling the fi xture as two discrete panels, six channels of DMX data are 
necessary. 

QuickPlay Pro enables you to confi gure ColorReach Powercore fi xtures as 3-channel or 
6-channel devices. However, LSM does not natively discover 6-channel ColorReach 
Powercore fi xtures (LSM maps all ColorReach Powercore fi xtures as 3-channel devices).
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LSM does not support 6-channel confi guration natively, but you can use the following 
steps to manually map 6-channel ColorReach Powercore fi xtures:

Steps 
1. Use QuickPlay Pro to confi gure your ColorReach fi xtures in 6-channel mode.

2. Discover all interfaces in the LSC Management Tool module.

3. Discover all fi xtures in the Management Tool module.

4. Select the mapped fi xtures to confi rm discovery — each ColorReach Powercore 
fi xture should turn into a red icon when selected. Note that LSC only displays one 
panel of nodes per discovered fi xture, rather than two panels.

5. For each fi xture, verify the light number offset using the light property editor. This 
is the base light number offset — write down each base light number offset.
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6. For each discovered fi xture, manually add an RGB fi xture to the map. Add one 
fi xture below each discovered fi xture, to create the second node panel.

7. For each manually added fi xture, set DMX the offset to the base offset + 3 (from 
step 5). This manually confi gures the remaining 3 DMX channels for the fi xture.

8. Highlight the manually added fi xtures to confi rm the confi guration. The manually 
added fi xtures should turn into red icons.

9. Create groups based on your installation needs.

10. Save the map and load it into Light System Composer.
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Appendix A: 
The LSC Interface
This appendix details the work environments, menus, and tools within each Light System 
Composer software module.

 Management Tool Module
The Management Tool Work Environment

Menu Bar  A list of on-screen functions or operations.

Tool Bar   A row of on-screen icons used to activate various functions.

Fixtures / Interfaces  A scrollable viewing area used to view and edit KiNET   
Panel   interfaces and fi xtures in your installation.

Groups Panel   A scrollable viewing area that lets you view and edit groups  
   assigned to your fi xtures.

Layout Panel   A scrollable viewing area that lets you view a virtual   
   representation of your installation.

Menu Bar
Tool Bar

Fixtures / Interfaces Panel

Groups Panel

Layout Panel
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 The Menus

The File Menu
The File menu commands apply to the maps as a whole, 
such as creating, opening, and saving a map.

The Edit Menu
The Edit menu commands include Undo, Redo, and 
Preferences.

The Light View Menu
The Light View menu commands apply to the light and 
interfaces portion of the map, such as discovering and 
adding fi xtures, and data interfaces.

The Group View Menu
The Group View menu lets you add and defi ne a new 
group to the map.

The Layout View Menu
The Layout View menu commands control the on-
screen appearance of the map, enables light selection 
live play, and creates animation templates for animated 
effects.

The Help Menu
The Help menu gives you version and build information 
about Management Tool software.
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 The Tool Bar

New Map
Click to create a new map.

Open Map
Click to open a previously saved map.

Save Map
Click to save the current map.

Discover Interfaces
Click to query and discover interfaces on the network.

Discover Lights
Click to query and discover fi xtures on the network.

Snap to Grid
Click to turn the Snap to Grid command On / Off.

Zoom In
Click to zoom in on Layout panel.

Zoom Out
Click to zoom out on Layout panel.

Add Interface
Click to add KiNET interface to map.

Add String
Click to add a fl exible string fi xtures, such as iColor Flex SL, to the map.

Add Tile
Click to add a tile fi xture, such as iColor Tile FX, to the map.

Add Module
Click to add a module fi xture, such as iColor Module FX, to the map.

Add Chromacore (Pro) Lights
Click to add Chromacore fi xtures to map.

Add White Lights
Click to add white light fi xtures to map.

Add Group
Click to add and defi ne a new group to the fi xtures.
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 Show Designer Module
The Show Designer Work Environment

Menu Bar  A list of on-screen functions or operations.

Tool Bar  A row of on-screen icons used to activate various   
   functions.

Effects Panel  A scrollable viewing area that lets you view and change   
   effects, and edit time and visual properties of the effects.

Simulation Window A scrollable viewing area that lets you see on screen, real  
   time effects and changes to your mapped fi xture icons.

Parameter Settings A dialog panel that lets you set and edit the properties of  
   each effect.

Time Settings  A dialog panel that lets you set and edit the run time for   
   each effect.

 The Menus

The File Menu
The fi le menu commands apply to the shows as a whole,  
such as loading maps for, creating, opening, and saving a 
show.

Menu Bar
Tool Bar

Effects Panel

Parameter Settings

Simulation Window

Time Settings
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The Edit Menu
The edit menu commands include Cut, Copy, Paste, Delete, Select All, and Preferences.

The Simulation Menu
The fi xture view menu commands apply to on screen viewing, and include show 
simulation, pause simulation, zoom in, and zoom out.

The Help Menu
The help menu gives you version and build information about Show Designer software. 

 The Tool Bar

Load Map
Click to load a map created in Management Tool. 

New Show
Click to create a new show. 

Open Show
Click to open a previously saved show.

Save Show
Click to save a show.

Write DMX
Click to save the show as a DMX format (for the legacy iPlayer 2 controller).

Cut Effect
Click to copy a currently highlighted effect to the clipboard and remove it from current 
location.

Copy Effect
Click to copy a currently highlighted effect to the clipboard.
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Paste Effect
Click to insert an effect from the clipboard to the effects panel.

Delete Effect
Click to delete a selected effect.

Zoom In
Click to zoom in on the simulation window.

Zoom Out
Click to zoom out on the simulation window.

Show Simulation
Click to display / hide the simulation window.

Parameter Settings
When an effect is selected, its effect parameters appear in the upper-right corner of the 
Show Designer main screen. Editing the effect parameters lets you customize your light 
show. With the show simulation feature, you can view the changes to the parameters as 
you make them.

Time Settings
When an effect is selected, its time settings appear in the lower-right corner of the Show 
Designer main screen. When creating a show, each effect is assigned an increment of 
time to run. Light shows are made up of multiple levels of timed effects. 

You can set the start and stop time for each effect by a given fi xed time, linked to other 
effect times, or by setting a fi xed number of cycles.

Effects Panel
As new effects are added, they appear in the effects panel of the Show Designer main 
screen. Each effect is displayed as a row in a table of effects. From this row you can edit 
the effect name, select and change the effect type, select or change the group, as well as 
set the priority, start, and end times, and fade in and fade out time. 

Simulation Window
The simulation window gives you a real-time view of your map layout with effects applied 
to the groups. As you assign new effects, edit effect parameters, and set effect times, you 
can see the changes immediately. The simulation window is an excellent alternative when 
you are unable to view the actual fi xtures in live-play mode.
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 The Confi g Maker Module
The Confi g Maker Work Environment

Menu Bar  A list of on-screen functions or operations

Zone   A dialog frame that lets you create zones that are   
   associated with maps, to which you add shows.

Keypad Button Setup A dialog frame that lets you assign actions to keypad   
   triggers.

Scheduled Events A dialog frame that lets you set schedule show events.

 The Menus

The File Menu
The fi le menu commands enable you to open confi gurations, save confi gurations (as .EFG 
fi les), and exit the Confi guration Tool.

The Confi guration Menu
The confi guration menu commands enable you to add zones, keypads, and schedules to 
confi gurations. From the menu, you can also discover Ethernet keypads.

The Controller Menu
The controller menu commands enable you to upload LSE fi les to your computer, save 
new (download) confi guration fi les to the LSE, and remove old fi les (clear fi les) from the 
LSE before downloading new fi les.

Menu Bar

Keypad Button Setup

Scheduled Events
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 The Playback Control Module

 The Playback Control Work Environment
Menu Bar   A list of on-screen functions or operations

Shows Tab   A dialog frame that lets view shows downloaded to the   
   LSE.

Info Tab   A text frame that lets you view current confi guration   
   information.

Scheduled Events Tab A text frame that lets you view event schedules

 The Menus

The File Menu
The File menu commands lets you pause the controller, refresh the screens and exit 
Playback Control.

The Action Menu
The Action menu commands.

Menu Bar

Tool Bar
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Appendix B: 
DMX Table

Light Number DMX Channels
1 1, 2, 3
2 4, 5, 6
3 7, 8, 9
4 10, 11, 12
5 13, 14, 15
6 16, 17, 18
7 19, 20, 21
8 22, 23, 24
9 25, 26, 27
10 28, 29, 30
11 31, 32, 33
12 34, 35, 36
13 37, 38, 39
14 40, 41, 42
15 43, 44, 55
16 46, 47, 48
17 49, 50, 51
18 52, 53, 54
19 55, 56, 57
20 58, 59, 60
21 61, 62, 63
22 64, 65, 66
23 67, 68, 69
24 70, 71, 72
25 73, 74, 75
26 76, 77, 78
27 79, 80, 81
28 82, 83, 84
29 85, 86, 87
30 88, 89, 90
31 91, 92, 93
32 94, 95, 96
33 97, 98, 99
34 100, 101, 102
35 103, 104, 105
36 106, 107, 108
37 109, 110, 111
38 112, 113, 114
39 115, 116, 117
40 118, 119, 120
41 121, 122, 123

Light Number DMX Channels
42 124, 125, 126
43 127, 128, 129
44 130, 131, 132
45 133, 134, 135
46 136, 137, 138
47 139, 140, 141
48 142, 143, 144
49 145, 146, 147
50 148, 149, 150
51 151, 152, 153
52 154, 155, 156
53 157, 158, 159
54 160, 161, 162
55 163, 164, 165
56 166, 167, 168
57 169, 170, 171
58 172, 173, 174
59 175, 176, 177
60 178, 179, 180
61 181, 182, 183
62 184, 185, 186
63 187, 188, 189
64 190, 191, 192
65 193, 194, 195
66 196, 197, 198
67 199, 200, 201
68 202, 203, 204
69 205, 206, 207
70 208, 209, 210
71 211, 212, 213
72 214, 215, 216
73 217, 218, 219
74 220, 221, 222
75 223, 224, 225
76 226, 227, 228
77 229, 230, 231
78 232, 233, 234
79 235, 236, 237
80 238, 239, 240
81 241, 242, 243
82 244, 245, 246
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Light Number DMX Channels
83 247, 248, 249
84 250, 251, 252
85 253, 254, 255
86 256, 257, 258
87 259, 260, 261
88 262, 263, 264
85 253, 254, 255
86 256, 257, 258
87 259, 260, 261
88 262, 263, 264
89 265, 266, 267
90 268, 269, 270
91 271, 272, 273
92 274, 275, 276
93 277, 278, 279
94 280, 281, 282
95 283, 284, 285
96 286, 287, 288
97 289, 290, 291
98 292, 293, 294
99 295, 296, 297
100 298, 299, 300
101 301, 302, 303
102 304, 305, 306
103 307, 308, 309
104 310, 311, 312
105 313, 314, 315
106 316, 317, 318
107 319, 320, 321
108 322, 323, 324
109 325, 326, 327
110 328, 329, 330
111 331, 332, 333
112 334, 335, 336
113 337, 338, 339
114 340, 341, 342
115 343, 344, 345
116 346, 347, 348
117 349, 350, 351
118 352, 353, 354
119 355, 356, 357
120 358, 359, 360
121 361, 362, 363
122 364, 365, 366
123 367, 368, 369
124 370, 371, 372

Light Number DMX Channels
125 373, 374, 375
126 376, 377, 378
127 379, 380, 381
128 382, 383, 384
129 385, 386, 387
130 388, 389, 390
131 391, 392, 393
132 394, 395, 396
133 397, 398, 399
134 400, 401, 402
135 403, 404, 405
136 406, 407, 408
137 409, 410, 411
138 412, 413, 414
139 415, 416, 417
140 418, 419, 420
141 421, 422, 423
142 424, 425, 426
143 427, 428, 429
144 430, 431, 432
145 433, 434, 435
146 436, 437, 438
147 439, 440, 441
148 442, 443, 444
149 445, 446, 447
150 448, 449, 450
151 451, 452, 453
152 454, 455, 456
153 457, 458, 459
154 460, 461, 462
155 463, 464, 465
156 466, 467, 468
157 469, 470, 471
158 472, 473, 474
159 475, 476, 477
160 478, 479, 480
161 481, 482, 483
162 484, 485, 486
163 487, 488, 489
164 490, 491, 492
165 493, 494, 495
166 496, 497, 498
167 499, 500, 501
168 502, 503, 504
169 505, 506, 507
170 508, 509, 510
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Appendix C: Basic Network
Troubleshooting

During Mapping and System Setup

Case 1: Cannot Discover PDS / Data Enablers or LSE
1. Check Network Specifi cations

Cabling: Are the cables factory cables (did they come with connectors attached)?

 If no, check all cables.

Cabling: Is the Ethernet cable run length within spec?

 The maximum cable run length is 323 ft (100 m) for CAT-5e.

Ethernet Switches: If using managed switches, use switch utility to verify connection.

2. LSE network port inactive? (neither power nor data indicator light is on)

Boot Sequence: Hook up a monitor to the LSE and look to see if the boot process is 
stopping because the BIOS is looking for a keyboard.

3. Computer Confi guration

Settings: IP address must be in the IP address range of 10.x.x.x and have a subnet 
mask of 255.0.0.0. If settings were incorrect, verify accepted change before 
continuing.

Active wireless connection: Disable the wireless network card.

Utility software: Disable all fi rewalls, anti-virus software, and VPNs.

Case 2: Cannot Discover Fixtures, but can discover PDS / Data Enablers or LSE
1. Check Network Specifi cations

Cabling: Are the cables factory cables (did they come with connectors attached)?

 If no, check all cables.

Cabling: Is the Ethernet cable run length within spec?

 The maximum cable run length is 323 ft (100 m) for CAT-5e.

Ethernet Switches: If using managed switches, use switch utility to verify connection.

2. Computer Confi guration

Settings: IP address must be in the IP address range of 10.x.x.x and have a subnet 
mask of 255.0.0.0. If settings were incorrect, verify accepted change before 
continuing.

Active wireless connection: Disable the wireless network card.

Utility software: Disable all fi rewalls, anti-virus software, and VPNs.
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Case 3: Cannot connect to LSE; all other network components are accessible
1. Test Network Cables / Switches

Cables: If cables / switches are suspected, use a crossover cable to directly connect 
the computer and LSE and verify connectivity.

2. Ping LSE

Ping 10.1.3.101. If “request timed out”, check the LSE’s network activity light. 

3. Reboot

Make sure LSE boots completely.

 If an incomplete boot is suspected, attach a monitor; if a keyboard or mouse is  
 requested, connect a keyboard or mouse, accordingly.

Post Mapping (the lighting installation has been functional for a period of time)

Case 1: Cannot Discover PDS / Data Enablers or LSE
1. Computer Confi guration 

Settings: IP address must be in the IP address range of 10.x.x.x and have a subnet 
mask of 255.0.0.0. If settings were incorrect, verify accepted change before 
continuing

Active wireless connection: Disable the wireless network card.

Utility software: Turn off all fi rewalls, anti-virus software, and VPNs.

2. Network

Cabling: Were the cables factory cables (did they come with connectors attached)?

 If no, check all cables.

Ethernet Switches: Switches can fail; use a switch tester to verify that the switches 
are functional

Case 2: Cannot Discover Fixtures, but can discover PDS / Data Enablers or LSE
1. Computer Confi guration 

Settings: IP address must be in the IP address range of 10.x.x.x and have a subnet 
mask of 255.0.0.0. If settings were incorrect, verify accepted change before 
continuing

Active wireless connection: Disable the wireless network card.

Utility software: Turn off all fi rewalls, anti-virus software, and VPNs.

2. Network

Cabling: Were the cables factory cables (did they come with connectors attached)?

 If no, check all cables.

Ethernet Switches: Switches can fail; use a switch tester to verify that the switches 
are functional
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Case 3: Cannot connect to LSE; all other network components are accessible
1. Test Network Cables / Switches

Cables: If cables / switches are suspected, use a crossover cable to directly connect 
the computer and LSE and verify connectivity.

2. Ping LSE

Ping 10.1.3.101. If “request timed out”, check the LSE’s network activity indicator 
light.

3. Reboot

Make sure LSE boots completely.

 If an incomplete boot is suspected, attach a monitor; if a keyboard or mouse  
 is requested, connect a keyboard or mouse, accordingly.

Case 4: Some Fixtures Do Not Work
1. Network

Check connections to all PDS/DE units

 Rediscover all lighting components using Management Tool. If some   
 components don’t register, begin the Network troubleshooting processes   
 listed in the previous cases.

 Technical Support Contacts
Contact Philips Color Kinetics technical support for assistance with hardware or 
software questions:

Phone
888.Full.RGB, press option number 3 (toll free US, Canada and Mexico)

617.423.9999, press option number 3 (toll worldwide)

Email
technicalsupport@colorkinetics.com

Web
www.colorkinetics.com/support
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Index

A
Addressing, methods  13
Animation effect  59
Animation template, creation  43
AuxBox  6, 10
AuxBox, confi guring triggers  75

C
CAT-5e cables  9, 13, 18
Chasing Rainbow effect  51
Confi g Maker  10, 14, 65
Confi g Maker, interface  93
Confi g Maker, menus  93
Confi guration Calculator  13
Controller Keypad, Ethernet  6
Controller Keypad,Ethernet, 

discovery process  76
Controller Keypads, Ethernet  13, 73
Controller Keypads, Ethernet, 

confi guring triggers  74
Controller Keypads, serial  73
Cross Fade effect  52
Custom Rainbow effect  53

D
DHCP confi guration, Mac OS X  21
DHCP confi guration, Windows PC  

20
Download fi les to LSE  71

E
Editing fi xture orientation and 

position  40
Effects  15
Effects, editing  48
Effects, end time  48
Effects, list of and parameters  51
Effects, priority  48
Effect start time  48

F
Fixed Color effect  54
Fixtures, automatic discovery  28
Fixtures, Chromacore  30, 36

Fixtures, Chromasic  28
Fixtures, ColorReach Powercore  

28, 84
Fixtures, module type  36
Fixtures, onscreen selection  39
Fixtures, string type  34
Fixtures, tile type  34

G
Groups  41
Groups, chasing  41
Groups, synchronized  41

I
Image Scroll effect  60
iPlayer 2, downloader utility  11
iPlayer 2, downloader utlity  81
iPlayer 2, support  6
Isolated LAN  12

K
Keypad Confi g Tool  11, 80
KiNET interfaces, discovering  27
KiNET protocol  6, 9, 12

L
Live Play  47
LSC, software installation  22
LSC, update software version  26
LSE, hard drive  9
LSE, hardware overview  9
LSE, interface  19
LSE, interface login  19
LSE, IP address  13
LSE, update fi rmware  25
LSE, upload to  14

M
Management Tool  10, 14
Management Tool, interface  87
Management Tool, menus  88
Management Tool, tool bar  89
MAP fi les  65
Mapping fi xtures  29, 34

Mapping fi xtures, automatic process  
27

Mapping fi xtures, manual process  33

N
Network installation checklist  18

P
Placeholder maps  33, 38
Playback Control  10, 14
Playback Control, interface  94
Playback Control, menus  94
Playback Control, overview  77
Playback Control, triggering shows 

from computer  77

Q
QuickPlay Pro  11, 13, 79

R
Random Color effect  54

S
Scheduling, example  69
Scheduling, overivew  68
Scheduling, recurrence parameters  68
Scheduling shows  6
Scroll Image effect, calculating X-Y 

settings  62
Show creation  45
Show designer  46
Show Designer  10, 14
Show Designer, interface  90
Show Designer, menus  90
Show Designer, tool bar  91
Show, saving fi le  50
Sparkle effect  55
Streak effect  56
Sweep effect  57
Switch, Fast Ethernet  12
Switch, Gigabit Ethernet  12
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T
Technical Support contacts  8

W
White Cross Fade effect  63
White Fixed Color effect  64

X
XY Burst effect  57
XY Spiral effect  58

Z
Zones  6, 15, 66
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